您的位置:首页 > 编程语言 > Go语言

poj 2909 Goldbach's Conjecture (哥德巴赫猜想)

2015-08-22 14:43 615 查看
Goldbach's Conjecture

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 10364Accepted: 6143
Description

For any even number n greater than or equal to 4, there exists at least one pair of prime numbers p1 and p2 such that

n = p1 + p2

This conjecture has not been proved nor refused yet. No one is sure whether this conjecture actually holds. However, one can find such a pair of prime numbers, if any, for a given even number. The problem here is to write a program that reports the number of all the pairs of prime numbers satisfying the condition in the conjecture for a given even number.

A sequence of even numbers is given as input. There can be many such numbers. Corresponding to each number, the program should output the number of pairs mentioned above. Notice that we are interested in the number of essentially different pairs and therefore you should not count (p1, p2) and (p2, p1) separately as two different pairs.

Input

An integer is given in each input line. You may assume that each integer is even, and is greater than or equal to 4 and less than 215. The end of the input is indicated by a number 0.

Output

Each output line should contain an integer number. No other characters should appear in the output.

Sample Input

6
10
12
0

Sample Output

1
2
1

Source

水题

写一遍的目的是。。。复习一下快速筛的写法 喵呜

/*************************************************************************
> File Name: code/poj/2909.cpp
> Author: 111qqz
> Email: rkz2013@126.com
> Created Time: 2015年08月22日 星期六 14时25分34秒
************************************************************************/

#include<iostream>
#include<iomanip>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstring>
#include<string>
#include<map>
#include<set>
#include<queue>
#include<vector>
#include<stack>
#define y0 abc111qqz
#define y1 hust111qqz
#define yn hez111qqz
#define j1 cute111qqz
#define tm crazy111qqz
#define lr dying111qqz
using namespace std;
#define REP(i, n) for (int i=0;i<int(n);++i)
typedef long long LL;
typedef unsigned long long ULL;
const int inf = 0x3f3f3f3f;
const int N=1<<16;
bool not_prime
;
int prime
;
int prime_num;
int n;

void init(){
not_prime[0] = true;
not_prime[1] = true;
for ( int i  =2 ; i < N ; i++){
if (!not_prime[i]){
prime[++prime_num] = i;
}
for ( int j = 1  ; j <= prime_num&&i*prime[j]<N ; j++){
not_prime[i*prime[j]] = true;
if (i%prime[j]==0) break;
}
}
}
int main()
{
init();
int n ;
while (scanf("%d",&n)&&n){
int ans = 0 ;
for ( int i = 2 ; i <= n /2 ; i++){
if (!not_prime[i]&&!not_prime[n-i]){
ans++;
}
}
printf("%d\n",ans);
}

return 0;
}


View Code
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: