您的位置:首页 > 其它

HDU 1405 The Last Practice

2015-08-22 12:39 387 查看

Description

Tomorrow is contest day, Are you all ready?

We have been training for 45 days, and all guys must be tired.But , you are so lucky comparing with many excellent boys who have no chance to attend the Province-Final.

Now, your task is relaxing yourself and making the last practice. I guess that at least there are 2 problems which are easier than this problem.

what does this problem describe?

Give you a positive integer, please split it to some prime numbers, and you can got it through sample input and sample output.

Input

Input file contains multiple test case, each case consists of a positive integer n(1

Output

For each test case you should output its factor as sample output (prime factor must come forth ascending ), there is a blank line between outputs.

Sample Input

60

12

-1

Sample Output

Case 1.

2 2 3 1 5 1

Case 2.

2 2 3 1

Hint

60=2^2*3^1*5^1

题意:

将给定的数据进行质因子分解,输出格式有坑,每个案例输出后面有空格,最后一个案例没有空行


代码实现

#include<iostream>
using namespace std;
#define MAXN 100

int main()
{
int n,t=1,test=0;
while(scanf("%d",&n)&&n>0)
{
if(test)
printf("\n");
int ans1[MAXN]={0};
int ans2[MAXN]={0};
int cnout=0;
for(int i=2;i<=n;i++)
{
if(n%i==0)
{
ans1[cnout]=i;
while(n%i==0)
{
ans2[cnout]++;
n/=i;
}
cnout++;
}

}
int j;
printf("Case %d.\n",t++);
for(j=0;j<cnout;j++)
printf("%d %d ",ans1[j],ans2[j]);
printf("\n");
test=true;
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: