您的位置:首页 > 其它

LightOJ1104---Birthday Paradox (概率)

2015-08-22 12:23 316 查看

Description

Sometimes some mathematical results are hard to believe. One of the common problems is the birthday paradox. Suppose you are in a party where there are 23 people including you. What is the probability that at least two people in the party have same birthday? Surprisingly the result is more than 0.5. Now here you have to do the opposite. You have given the number of days in a year. Remember that you can be in a different planet, for example, in Mars, a year is 669 days long. You have to find the minimum number of people you have to invite in a party such that the probability of at least two people in the party have same birthday is at least 0.5.

Input

Input starts with an integer T (≤ 20000), denoting the number of test cases.

Each case contains an integer n (1 ≤ n ≤ 105) in a single line, denoting the number of days in a year in the planet.

Output

For each case, print the case number and the desired result.

Sample Input

2

365

669

Sample Output

Case 1: 22

Case 2: 30

题解:

题意

生日悖论

23个人里有两个生日相同的人的几率有多大呢?

居然有50%

问题是这样的: 如果一个房间里有23个或23个以上的人,那么至少有两个人的生日相同的概率要大于50%。这就意味着在一个典型的标准小学班级(30人)中,存在两人生日相同的可能性更高。对于60或者更多的人,这种概率要大于99%。

不计特殊的年月,如闰二月。

先计算房间里所有人的生日都不相同的概率,那么

第一个人的生日是 365选365

第二个人的生日是 365选364

第三个人的生日是 365选363

:

:

:

第n个人的生日是 365选365-(n-1)

所以所有人生日都不相同的概率是:

那么,n个人中有至少两个人生日相同的概率就是:

所以当n=23的时候,概率为0.507

当n=100的时候,概率为0.9999996

用简单的循环就可以暴力解出来

#include<iostream>
#include<cstdio>
using namespace std;
int main()
{
int t,cnout;
cnout=1;
cin >> t;
while (t--)
{
double n,sum=1;
int i;
double p = 0;
cin >> n;
for ( i = 1; i < 100010; i++){
p = (n - i + 1) / n;
sum*=p;
if (1 - sum >= 0.5)
break;
}

cout <<"Case "<< cnout++<<": "<<i-1<< endl;
}

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: