您的位置:首页 > 其它

hdoj 1010Tempter of the Bone【DFS】

2015-08-21 21:49 274 查看


Tempter of the Bone


Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)


Total Submission(s) : 8 Accepted Submission(s) : 4


Problem Description

The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the
T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for
more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.

Input

The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the
maze layout, with each line containing M characters. A character is one of the following: 'X': a block of wall, which the doggie cannot enter; 'S': the start point of the doggie; 'D': the Door; or '.': an empty block. The input is terminated with three 0's.
This test case is not to be processed.

Output

For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.

Sample Input

4 4 5
S.X.
..X.
..XD
....
3 4 5
S.X.
..X.
...D
0 0 0


Sample Output

NO
YES


解题用DFS,可是存在超时问题,所以用到 ”奇偶剪枝“ 就是非奇(数)同偶(数);奇偶性相同的两个数相加减结果还是偶数,反之为奇数。abs(si-sj)+abs(di-dj) 的奇偶性就确定了所需要的步数 t 的奇偶性。

由于图不大才7*7,再加上图的总块数减去X的个数与t相比,判断更省时间(从800+ms降到300+ms)



AC代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>
using namespace std;
char map[10][10];
int n,m,t,flag;
int sx,sy,ex,ey;
int dir[][2]={1,0,0,-1,0,1,-1,0};
void dfs(int x,int y,int b)
{
if(flag || b>t)  return;
if(x<0 || y<0 || x>=n || y>=m || map[x][y]=='X')	return;
if(x==ex&&y==ey&&b==t)
{
flag = 1;
return;
}
for(int i = 0;i < 4; i++)
{
map[x][y] = 'X';
int dx = x+dir[i][0];
int dy = y+dir[i][1];

dfs(dx,dy,b+1);
map[x][y] = '.';
}
}
int main()
{
int i,j,k;
while(scanf("%d%d%d",&n,&m,&t)!=EOF,n|m|t)
{
flag = 0;
int wall = 0;
for(i = 0; i < n;i++)
scanf("%s",map[i]);
for(i = 0; i < n; i++)
{
for(j = 0; j < m; j++)
{
if(map[i][j] == 'S')
{
sx = i;
sy = j;
}
if(map[i][j] == 'D')
{
ex = i;
ey = j;
}
if(map[i][j] == 'X')
wall++;
}
}
if((t-(abs(ex-sx)+abs(ey-sy)))&1 || n*m-wall<=t)
{
printf("NO\n");
}
else
{
dfs(sx,sy,0);
if(flag)
printf("YES\n");
else
printf("NO\n");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: