您的位置:首页 > 其它

UVA 101 The Blocks Problem

2015-08-21 09:45 417 查看

Background 

Many areas of Computer Science use simple, abstract domains for both analytical and empirical studies. For example, an early AI study of planning and robotics (STRIPS) used a block world in which a robot arm
performed tasks involving the manipulation of blocks.
In this problem you will model a simple block world under certain rules and constraints. Rather than determine how to achieve a specified state, you will ``program'' a robotic arm to respond to a limited set of
commands.

The Problem 

The problem is to parse a series of commands that instruct a robot arm in how to manipulate blocks that lie on a flat table. Initially there are n blocks
on the table (numbered from 0 to n-1) with block bi adjacent
to block bi+1 for all 

 as
shown in the diagram below:
 

Figure: Initial Blocks World

The valid commands for the robot arm that manipulates blocks are:
move a onto b
where a and b are block numbers, puts block a onto block b after returning any blocks that are stacked on top of blocks a and b to their initial positions.

move a over b
where a and b are block numbers, puts block a onto the top of the stack containing block b, after returning any blocks that are stacked on top of block a to their initial positions.

pile a onto b
where a and b are block numbers, moves the pile of blocks consisting of block a, and any blocks that are stacked above block a, onto block b. All blocks on top of block b are moved to their initial positions
prior to the pile taking place. The blocks stacked above block a retain their order when moved.

pile a over b
where a and b are block numbers, puts the pile of blocks consisting of block a, and any blocks that are stacked above block a, onto the top of the stack containing block b. The blocks stacked above block aretain
their original order when moved.

quit
terminates manipulations in the block world.

Any command in which a = b or in which a and b are in the same stack of blocks is an illegal command. All illegal commands should be ignored and should have no affect on the configuration
of blocks.

The Input 

The input begins with an integer n on a line by itself representing the number of blocks in the
block world. You may assume that 0 < n < 25.
The number of blocks is followed by a sequence of block commands, one command per line. Your program should process all commands until the quit command is encountered.
You may assume that all commands will be of the form specified above. There will be no syntactically incorrect commands.

The Output 

The output should consist of the final state of the blocks world. Each original block position numbered i (

 where n is
the number of blocks) should appear followed immediately by a colon. If there is at least a block on it, the colon must be followed by one space, followed by a list of blocks that appear stacked in that position with each block number separated from other
block numbers by a space. Don't put any trailing spaces on a line.
There should be one line of output for each block position (i.e., n lines of output where n is the integer on the first line of input).

Sample Input 

10
move 9 onto 1
move 8 over 1
move 7 over 1
move 6 over 1
pile 8 over 6
pile 8 over 5
move 2 over 1
move 4 over 9
quit


Sample Output 

0: 0
1: 1 9 2 4
2:
3: 3
4:
5: 5 8 7 6
6:
7:
8:
9:


紫书的例题
move a onto b:把a和b上方的木块全部归位,然后把a摞在b上面。 
move a over b:把a上方的木块全部归位,然后把a放在b所在木块堆的顶部。 
pile a onto b:把b上方的木块全部归位,然后把a及上面的木块整体摞在b上面。 
pile a over b:把a及上面的木块整体摞在b所在木块堆的顶部。

注意当a,b在同一堆的时候为非法指令
#include<cstdio>
#include<iostream>
#include<vector>
#include<string>
using namespace std;

vector<int>vv[27];
int n;
void hl(int a,int& h,int& l)
{
for(h=0;h<n;h++)
for(l=0;l<vv[h].size();l++)
if(vv[h][l]==a)
return;
}
void guiwei(int h0,int l0)
{
for(int i=l0+1;i<vv[h0].size();i++)
{
int p=vv[h0][i];
vv[p].push_back(p);
}
vv[h0].resize(l0+1);
}
void pile_onto(int h,int l,int h1)
{
for(int i=l;i<vv[h].size();i++)
{
vv[h1].push_back(vv[h][i]);
}
vv[h].resize(l);
}

void print(int n)
{
for(int j=0;j<n;j++)
{
cout<<j<<":";
for(int i=0;i<vv[j].size();i++)
cout<<" "<<vv[j][i];
cout<<endl;
}
}
int main()
{
cin>>n;
for(int i=0;i<n;i++)
vv[i].push_back(i);
int m1,m2;
string s1,s2;
while(cin>>s1>>m1>>s2>>m2)
{
int h1,h2,l1,l2;
hl(m1,h1,l1);
hl(m2,h2,l2);
if(h1==h2)
continue;
if(s2=="onto")
guiwei(h2,l2);
if(s1=="move")
guiwei(h1,l1);
pile_onto(h1,l1,h2);
}
print(n);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: