您的位置:首页 > 其它

hdu-2717 Catch That Cow (BFS)

2015-08-21 01:07 429 查看

Catch That Cow

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 9744    Accepted Submission(s): 3048


[align=left]Problem Description[/align]
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer
John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute

* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
 

[align=left]Input[/align]
Line 1: Two space-separated integers: N and K
 

[align=left]Output[/align]
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
 

[align=left]Sample Input[/align]

5 17

 

[align=left]Sample Output[/align]

4

HintThe fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.第一道BFS题
# include<cstdio>
# include<cstring>
# include<queue>
# include<algorithm>
# define MAXM 100000 + 100
using namespace std;
int num[MAXM];
int vis[MAXM];

void bfs(int start, int end)
{
int now, next;
int i, j;
queue<int>q;
q.push(start);
vis[start] = 1;
while(!q.empty())
{
now = q.front();
q.pop();
if(now == end) break;
next = now + 1;
if(!vis[next] && next <= end)
{
num[next] = num[now] + 1;
vis[next] = 1;
q.push(next);
}
next = now - 1;
if(!vis[next] && next >= 0)
{
num[next] = num[now] + 1;
vis[next] = 1;
q.push(next);
}
next = now * 2;
if(!vis[next] && next <= MAXM)
{
num[next] = num[now] + 1;
vis[next] = 1;
q.push(next);
}
}
printf("%d\n",num[end]);
}

int main()
{
int i, j;
int start, end;
while(scanf("%d%d",&start,&end)!=EOF)
{
memset(vis, 0, sizeof(vis));
memset(num, 0, sizeof(num));
bfs(start, end);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: