您的位置:首页 > 其它

HDU 3336 KMP

2015-08-20 21:07 197 查看
Count the string

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 6523 Accepted Submission(s): 3021

Problem Description

It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:

s: “abab”

The prefixes are: “a”, “ab”, “aba”, “abab”

For each prefix, we can count the times it matches in s. So we can see that prefix “a” matches twice, “ab” matches twice too, “aba” matches once, and “abab” matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For “abab”, it is 2 + 2 + 1 + 1 = 6.

The answer may be very large, so output the answer mod 10007.

Input

The first line is a single integer T, indicating the number of test cases.

For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.

Output

For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.

Sample Input

1

4

abab

Sample Output

6

KMP算法。 。此题有BUG,交题时abracadabra会得出错误结果。无意间AC了。 。但是解决BUG的方法一直没想到。 。

#include <cstdio>
#include <algorithm>
#include <cstring>
#include <iostream>
//#define LOCAL
using namespace std;
char C[200010];
int p[200010];
int n;

void getFail(void){
int i,j;
p[0] = p[1] = 0;
for(i = 1;i<n;i++){
j = p[i];
while(j&&C[i]!=C[j])
j = p[j];
p[i+1] = C[i] == C[j] ? j+1 : 0;
}

}

int main(){
#ifdef LOCAL
freopen("data.in","r",stdin);
#endif // LOCAL
int N;
scanf("%d",&N);
while(N--){
scanf("%d",&n);
scanf("%s",C);
getFail();
int sum = n + p
;
for(int i = 0;i<n;i++){
if(p[i]&&p[i+1]!=p[i]+1)
sum += p[i];
}
printf("%d\n",sum%10007);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  string kmp