您的位置:首页 > 其它

hdoj 2717 Catch That Cow

2015-08-20 20:08 375 查看


Catch That Cow

Time Limit: 5000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 9719 Accepted Submission(s): 3043



Problem Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of
transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute

* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?



Input

Line 1: Two space-separated integers: N and K



Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.



Sample Input

5 17




Sample Output

4题目大意:一个人在追一个宠物,有两种方式,步行:每秒前进或后退1步;                            借助传输工具:每秒前进2*x步;代码:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#include<queue>
int x,ex,ans;
int n,m;
int visit[100005];
struct line 
{
    int x;
    int step;
};
int  bfs()//广搜 
{
    queue<line>Q;
    while(!Q.empty() )
    Q.pop();
    memset(visit,0,sizeof(visit));
    int i;
    line next,now;
    now.step =0;
    now.x=n;
    visit
=1;
    Q.push(now);
    while(!Q.empty() )
    {
        now=Q.front() ;
        Q.pop() ;
        for(i=0;i<3;i++)//三种不同的移动方式 
         {
             if(i==0)
                 next.x =now.x -1;
             else if(i==1)
                 next.x =now.x +1;
             else
                  next.x =now.x*2;
              next.step =now.step +1;
              if(next.x==m)
              return next.step;
              if(next.x >=0&&next.x<=100000&&!visit[next.x ])
              {
                  Q.push(next ); 
                  visit[next.x ]=1;
              }
         }
     } 
     return 0;
}
int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        x=n;ex=m;
        if(x>=ex)//当人的位置大于pet的位置时,直接减,即可! 
        {
        printf("%d\n",x-ex);
        continue;
        }
    int s=bfs();
        printf("%d\n",s);
    }
    return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: