您的位置:首页 > 产品设计 > UI/UE

Advanced Fruits

2015-08-20 19:56 387 查看
[align=left]Problem Description[/align]
[align=left] [/align]
The company "21st Century Fruits" has specialized in creating new sorts of fruits by transferring genes from one fruit into the genome of another one. Most times this method doesn't work, but sometimes,
in very rare cases, a new fruit emerges that tastes like a mixture between both of them.

A big topic of discussion inside the company is "How should the new creations be called?" A mixture between an apple and a pear could be called an apple-pear, of course, but this doesn't sound very interesting. The boss finally decides to use the shortest string
that contains both names of the original fruits as sub-strings as the new name. For instance, "applear" contains "apple" and "pear" (APPLEar and apPlEAR), and there is no shorter string that has the same property.

A combination of a cranberry and a boysenberry would therefore be called a "boysecranberry" or a "craboysenberry", for example.

Your job is to write a program that computes such a shortest name for a combination of two given fruits. Your algorithm should be efficient, otherwise it is unlikely that it will execute in the alloted time for long fruit names.

[align=left]Input[/align]
[align=left] [/align]
Each line of the input contains two strings that represent the names of the fruits that should be combined. All names have a maximum length of 100 and only consist of alphabetic characters.

Input is terminated by end of file.

[align=left]Output[/align]
[align=left] [/align]
For each test case, output the shortest name of the resulting fruit on one line. If more than one shortest name is possible, any one is acceptable.

[align=left]Sample Input[/align]
[align=left] [/align]

apple peach
ananas banana
pear peach


[align=left]Sample Output[/align]
[align=left] [/align]

appleach
bananas
pearch

合并两个字符串,最长公共子序列的应用,找出两个字符串的LCS,然后构造目标字符串。例如,有两个字符串

apple pffeach

这两个字符串的LCS是P E

那么分别找出P,E在两个字符串的位置,再将不属于LCS的字符插进来,就变成了:

(a) P (pl) (ff) E (ach)

<span style="color:#000000;">#include<stdio.h>
#include<string.h>
#define MAX(a,b) a>b?a:b
char s1[110],s2[110],s[210];//当时s[110]开的太小了,一直WA!!!
int dp[110][110];
int main()
{
while(scanf("%s%s",s1,s2)!=EOF)
{
memset(dp,0,sizeof(dp));//dp数组不清零的话,会出错
int len1=strlen(s1);
int len2=strlen(s2);
int i,j;
for(i=1;i<=len1;i++)
{
for(j=1;j<=len2;j++)
{
if(s1[i-1]==s2[j-1])
dp[i][j]=dp[i-1][j-1]+1;
else
dp[i][j]=MAX(dp[i-1][j],dp[i][j-1]);
}
}
i=len1;
j=len2;
int k=0;
while(dp[i][j])//dp[0][0]==0,因为当时没有往里边存数据。
{//我感觉是LCS倒过来想了。
if(s1[i-1]==s2[j-1])//改到无奈了,才发现是“==”写成了“=”!!无语了
{
i--;
j--;//易错点
s[k++]=s1[i];
}
else if(dp[i-1][j]>dp[i][j-1])
{
i--;
s[k++]=s1[i];
}
else
{
j--;
s[k++]=s2[j];
}
}
while(i>=1)//或者写成while(i>0)这样好理解,for循环出来之后i>0,说明字符还没存完
s[k++]=s1[--i];
while(j>=1)//while(j>0)
s[k++]=s2[--j];
s[k]='\0';//给新串加上字符串结束标记,写不写无所谓。
for(i=k-1;i>=0;i--)//s数组当时是从0开始存的!
printf("%c",s[i]);
printf("\n");
}

return 0;
}</span>
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: