您的位置:首页 > 其它

poj 2240

2015-08-20 19:41 288 查看
Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French
franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent.

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.

Input

The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within
a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name
cj of the destination currency. Exchanges which do not appear in the table are impossible.

Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".

Sample Input

3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0


Sample Output
Case 1: YesCase 2: No

弗洛伊德的变式题,还有一个问题,如何把字符数组变成节点

#include <iostream>
#include <string.h>
#include <stdio.h>
using namespace std;
double e[50][50];
char a[50][50];
int n,m;
int zhuanhuan(char s[])
{
for(int i=1;i<=n;i++)
{
if(strcmp(a[i],s)==0)
return i;
}
}
int floyd()
{
for(int k=1;k<=n;k++)
{
for(int i=1;i<=n;i++)
{
for(int j=1;j<=n;j++)
{
if(e[i][j]<e[i][k]*e[k][j])
e[i][j]=e[i][k]*e[k][j];
}
}
}
for(int i=1;i<=n;i++)
{
if(e[i][i]>1)
return 1;
}
return 0;
}
int main()
{
char start[50],end[50];
int tmp=1,x,y;
double rate;
while(cin>>n&&n!=0)
{
for(int i=1;i<=n;i++)
{
for(int j=1;j<=n;j++)
{
e[i][j]=0;
}
}
for(int i=1;i<=n;i++)
{
cin>>a[i];
}
cin>>m;
for(int i=1;i<=m;i++)
{
cin>>start;
cin>>rate;
cin>>end;
x=zhuanhuan(start);
y=zhuanhuan(end);
e[x][y]=rate;
}
if(floyd())
printf("Case %d: Yes\n",tmp);
else
printf("Case %d: No\n",tmp);
tmp++;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: