您的位置:首页 > 其它

The least one

2015-08-20 19:11 211 查看
[align=left]Problem Description[/align]
[align=left][/align]
In the RPG game “go back ice age”(I decide to develop the game after my undergraduate education), all heros have their own respected value, and the skill of killing monsters is defined as
the following rule: one hero can kill the monstrers whose respected values are smaller then himself and the two respected values has none common factor but 1, so the skill is the same as the number of the monsters he can kill. Now each kind of value of the
monsters come. And your hero have to kill at least M ones. To minimize the damage of the battle, you should dispatch a hero with minimal respected value. Which hero will you dispatch ? There are Q battles, in each battle, for i from 1 to Q, and your hero should
kill Mi ones at least. You have all kind of heros with different respected values, and the values(heros’ and monsters’) are positive.


[align=left]Input[/align]
[align=left] [/align]
The first line has one integer Q, then Q lines follow. In the Q lines there is an integer Mi, 0<Q<=1000000, 0<Mi<=10000.



[align=left]Output[/align]
[align=left] [/align]
For each case, there are Q results, in each result, you should output the value of the hero you will dispatch to complete the task.

[align=left]Sample Input[/align]
[align=left] [/align]

2
3
7


[align=left]Sample Output[/align]


5

[align=left]11[/align]

题意:找与Q离得最近的素数

#include<stdio.h>
#include<math.h>
#include<string.h>
int is(int x)
{
if(x==0||x==1)
return 0;
else
{
int c;
c=sqrt(x*1.0);
for(int i=2;i<=c;i++)
{
if(x%i==0)
return 0;
//return 1;
}
return 1;
}

}
int main()
{
int n;
scanf("%d",&n);
while(n--)
{
int Q,i;
scanf("%d",&Q);
for(i=Q+1;;i++)
{
if(is(i))
{
printf("%d\n",i);
break;
}
}

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: