您的位置:首页 > 其它

HDOJ 2199 Can you solve this equation? (二分)

2015-08-20 17:20 323 查看

Can you solve this equation?

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 13402 Accepted Submission(s): 5977

[align=left]Problem Description[/align]
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;

Now please try your lucky.

[align=left]Input[/align]
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);

[align=left]Output[/align]
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.

[align=left]Sample Input[/align]

2
100
-4


[align=left]Sample Output[/align]

1.6152
No solution!


注 - 此题为: HDOJ 2199 Can you solve this equation? (二分)

二分法,注意精度

已AC代码:

#include<cstdio>

double fy(double x)
{
return 8*x*x*x*x + 7*x*x*x + 2*x*x + 3*x + 6;
}
double abs(double x)
{
if(x<0)
x=-1*x;
return x;
}
int main()
{
int T;
scanf("%d",&T);
while(T--)
{
double y;
scanf("%lf",&y);
if(y<fy(0)||y>fy(100))
{
printf("No solution!\n");
continue;
}

double mid,left=0,right=100;
while(right-left>1e-10)   // 二分
{
mid=(left+right)/2;
if(abs(fy(mid)-y)<1e-10)
break;
if(fy(mid)>y)
right=mid;
else
left=mid;
}
printf("%.4f\n",mid);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: