您的位置:首页 > 产品设计 > UI/UE

poj 2478 Farey Sequence

2015-08-20 17:13 387 查看
B - Farey Sequence
Time Limit:1000MS Memory Limit:65536KB 64bit
IO Format:
%I64d & %I64u

Description

The Farey Sequence Fn for any integer n with n >= 2 is the set of irreducible rational numbers a/b with 0 < a < b <= n and gcd(a,b) = 1 arranged in increasing order. The first few are

F2 = {1/2}

F3 = {1/3, 1/2, 2/3}

F4 = {1/4, 1/3, 1/2, 2/3, 3/4}

F5 = {1/5, 1/4, 1/3, 2/5, 1/2, 3/5, 2/3, 3/4, 4/5}

You task is to calculate the number of terms in the Farey sequence Fn.

Input

There are several test cases. Each test case has only one line, which contains a positive integer n (2 <= n <= 10 6). There are no blank lines between cases. A line with a single 0 terminates the input.

Output

For each test case, you should output one line, which contains N(n) ---- the number of terms in the Farey sequence Fn.

Sample Input

23540


Sample Output

1395


这道题的题意可以转化为对每一个数字输出它的上一位sum值加上不超过它的互素整数的和。
求每一位数的不超过它自身的互质整数用欧拉函数:
欧拉函数模板:
int a
;
void euler(int n){
memset(a,0,sizeof(a));
a[i]=1;
for(int i=2;i<=n;i++)
if(!a[i])
for(int j=i;j<=n;j+=i)
{
if(!a[j]) a[j]=j;
a[j]=a[j]/i*(i-1);
}
}
注意用 long long 开始用int sum[Max] WA了好几次。
代码:

#include<iostream>
#include<cstring>
#include<string>
using namespace std;
int a[1000005];
long long sum[1000005];
int n;
void phi_table(int n)
{
for(int i=2;i<=n;i++)
a[i]=0;
a[1]=1;
for(int i=2;i<=n;i++)
{if(!a[i])
for(int j=i;j<=n;j+=i)
{
if(!a[j]) a[j]=j;
a[j]=a[j]/i*(i-1);
}
}
}
int main(){
phi_table(1000000);
while(cin>>n&&n!=0)
{
memset(sum,0,sizeof(sum));
for(int i=2;i<=n;i++)
sum
=sum
+a[i];
cout<<sum
<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: