您的位置:首页 > 其它

HDOJ A strange lift(Dijkstra最短路问题)

2015-08-20 16:44 411 查看

A strange lift

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 16362    Accepted Submission(s): 6109


[align=left]Problem Description[/align]
There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press
the button "UP" , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button "DOWN" , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can't go up high than N,and can't go down lower
than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button "UP", and you'll go up to the 4 th floor,and if you press the button "DOWN", the lift can't do it, because
it can't go down to the -2 th floor,as you know ,the -2 th floor isn't exist.

Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button "UP" or "DOWN"?

 
[align=left]Input[/align]
The input consists of several test cases.,Each test case contains two lines.

The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn.

A single 0 indicate the end of the input.
 
[align=left]Output[/align]
For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can't reach floor B,printf "-1".
 
[align=left]Sample Input[/align]

5 1 5
3 3 1 2 5
0

 
[align=left]Sample Output[/align]

3

 
//题的意思是有一种很特别的电梯,这种电梯每层只有三个键,up,down,还有一个数字键n,当你按up键时,电梯将上升n层,按down键的时候,电梯将下降n层,给你开始和结束的层数,问至少按多少次才能从A到B,好奇特的电梯啊

,真想坐坐,很定很好玩

//解题思路,和最短路差不多,就好像坐公交车,没有直达车,而且每次只花费一分钟,问最短时间,一个意思,,上代码

 

#include<cstdio>
#include<cstring>
#include<algorithm>
#define INF 0x3f3f3f
using namespace std;
int map[220][220],sign[220],dis[220],n,a[220],s,e;
void Dijk(int s)
{
int i,j;
for (i=1;i<=n;i++)
{
sign[i]=0;
dis[i]=map[s][i];
}
sign[s]=1;
dis[s]=0;
while (1)
{
int t=-1;
for (i=1;i<=n;i++)
if (!sign[i]&&(t==-1||dis[i]<dis[t]))
t=i;
if (t==-1)
break;
sign[t]=1;
for (j=1;j<=n;j++)
{
if (dis[j]>dis[t]+map[t][j])
dis[j]=dis[t]+map[t][j];
}
}
}
int main()
{
while (scanf ("%d",&n)&&n!=0)
{
int i,j;
for (i=1;i<=n;i++)
for (j=1;j<=n;j++)
map[i][j]=INF;
scanf ("%d%d",&s,&e);
for (i=1;i<=n;i++)
{
scanf ("%d",&a[i]);
if ((i+a[i])<=n)//可上升,必须小于最高层
map[i][i+a[i]]=1;
if ((i-a[i])>=1)//可下降,必须大于最底层
map[i][i-a[i]]=1;
}
Dijk(s);
if (dis[e]==INF)
printf ("-1\n");
else
printf ("%d\n",dis[e]);
}
return 0;
}


 

 

 

 

 

 

 

 

 

 

 

 

搜索
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: