您的位置:首页 > 其它

POJ---1988-Cube Stacking(并查集)

2015-08-20 13:49 399 查看
Cube Stacking

Time Limit: 2000MSMemory Limit: 30000K
Total Submissions: 21361Accepted: 7478
Case Time Limit: 1000MS
Description

Farmer John and Betsy are playing a game with N (1 <= N <= 30,000)identical cubes labeled 1 through N. They start with N stacks, each containing a single cube. Farmer John asks Betsy to perform P (1<= P <= 100,000) operation. There are two types of operations:

moves and counts.

* In a move operation, Farmer John asks Bessie to move the stack containing cube X on top of the stack containing cube Y.

* In a count operation, Farmer John asks Bessie to count the number of cubes on the stack with cube X that are under the cube X and report that value.

Write a program that can verify the results of the game.

Input

* Line 1: A single integer, P

* Lines 2..P+1: Each of these lines describes a legal operation. Line 2 describes the first operation, etc. Each line begins with a 'M' for a move operation or a 'C' for a count operation. For move operations, the line also contains two integers: X and Y.For
count operations, the line also contains a single integer: X.

Note that the value for N does not appear in the input file. No move operation will request a move a stack onto itself.

Output

Print the output from each of the count operations in the same order as the input file.

Sample Input
6
M 1 6
C 1
M 2 4
M 2 6
C 3
C 4

Sample Output
1
0
2

Source

USACO 2004 U S Open

(并查集):

#include <iostream>
#include <cstring>
#include <algorithm>
#include <cstdio>
#include <stack>
#include <list>
#include <vector>
#include <map>
using namespace std;
const int maxn = 100005;
int set[maxn],cnt[maxn],top[maxn];
int set_find(int p)
{
if(set[p]<0)return p;
if(set[ set[p] ]>=0)
{
int fa=set[p];
set[p]=set_find(fa);
cnt[p]+=cnt[fa];
}
return set[p];
}
void set_join(int x,int y)
{
x=set_find(x);
y=set_find(y);
set[x]=y;
// set_find(top[y]);
cnt[x]=cnt[ top[y] ]+1;
top[y]=top[x];
set_find(top[y]);
}
int main()
{
int p;
scanf("%d",&p);
memset(set,-1,sizeof(set));
memset(cnt,0,sizeof(cnt));
for(int i=0; i<maxn; ++i)
top[i]=i;
while(p--)
{
char s;
int x,y;
cin>>s;
if(s=='M')
{
scanf("%d%d",&x,&y);
set_join(x,y);
}
else
{
scanf("%d",&x);
set_find(x);
printf("%d\n",cnt[x]);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: