您的位置:首页 > 其它

1056. Mice and Rice (25)

2015-08-19 23:48 295 查看



1056. Mice and Rice (25)

时间限制

30 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Mice and Rice is the name of a programming contest in which each programmer must write a piece of
code to control the movements of a mouse in a given map. The goal of each mouse is to eat as much rice as possible in order to become a
FatMouse.

First the playing order is randomly decided for NP programmers. Then every NG programmers are grouped in a match. The fattest mouse in a group wins and enters the next turn. All the losers in
this turn are ranked the same. Every NG winners are then grouped in the next match until a final winner is determined.

For the sake of simplicity, assume that the weight of each mouse is fixed once the programmer submits his/her code. Given the weights of all the mice and the initial playing order, you are supposed to output the ranks for the programmers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: NP and NG (<= 1000), the number of programmers and the maximum number of mice in a group, respectively.
If there are less than NG mice at the end of the player's list, then all the mice left will be put into the last group. The second line contains NP distinct non-negative numbers Wi (i=0,...NP-1)
where each Wi is the weight of the i-th mouse respectively. The third line gives the initial playing order which is a permutation of 0,...NP-1 (assume that the programmers are numbered from
0 to NP-1). All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the final ranks in a line. The i-th number is the rank of the i-th programmer, and all the numbers must be separated by a space, with no extra space at the end of the line.
Sample Input:
11 3
25 18 0 46 37 3 19 22 57 56 10
6 0 8 7 10 5 9 1 4 2 3

Sample Output:
5 5 5 2 5 5 5 3 1 3 5

一道挺有意思的题目,如果你注意到了第一段里的那个FatMouse就更有意思了,题目的要求是让你模拟一场比赛,n个参赛选手,k人一组,零头不足k也视为一组。然后每轮比赛决出一个冠军,进入下一组,直到最后只剩下一个人。所有在同一轮比赛中输掉的人排名相同,一开始纠结了好久排名应该如何确定,后来想到就是那一轮晋级的人数+1就好了,用pair<int,int>绑定重量与ID,用priority_queue得出胜利者,省下了不少代码。
# include <iostream>
# include <algorithm>
# include <queue>
using namespace std;

const int _size = 1005;
const int debug = 0;

int weight[_size];
int Rank[_size];

typedef pair<int,int> mice;
/*
a struct privided by the head file of algorithm ,
whose member veriables is "first & second",(there refer to "wegiht & id ")
the < operator is defined to attach priority to first
*/
int main()
{
int i,temp;
int n,k,total;
cin >> n >> k;
for (i=0;i<n;i++)
cin >> weight[i];

priority_queue<mice> pri_que;
mice winner[_size];
mice loser[_size];
for (i=0;i<n;i++)
{
cin >> temp;
winner[i] = mice(weight[temp],temp);
}

/**Here is the beginning of the main contest *************************/
total = n;      /*We assume every player is the winner of a previous game*/
while (total>1)
{
int e_win = 0;
int e_los = 0;
for (i=0;i<total;i+=k)
{
int begin = i,end = i+k<total?i+k:total;
while (begin<end)
{
pri_que.push(winner[begin]);
begin++;
}
winner[e_win++] = pri_que.top();pri_que.pop();/* by priority_que we can easily find the winner*/
while (!pri_que.empty())  /*After the winner is popped all player left is loser */
{
loser[e_los++] = pri_que.top();
pri_que.pop();
}
}
while (--e_los>=0)
Rank[loser[e_los].second] = e_win + 1;/*All the loser share the same rank which should be bigger than any winner*/
total = e_win;
}
Rank[winner[0].second] = 1;
/**Here is the ending of the main contest *************************/

for (i=0;i<n;i++)
cout << Rank[i] << (i==n-1?'\n':' ');
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: