您的位置:首页 > 其它

POJ1850——Code

2015-08-19 21:43 232 查看
[align=center]Code[/align]

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 8764 Accepted: 4167
数位dp;
题意很容易看懂;

Description
Transmitting and memorizing information is a task that requires different coding systems for the best use of the available space. A well known system is that one where a number is associated to a character sequence. It is considered
that the words are made only of small characters of the English alphabet a,b,c, ..., z (26 characters). From all these words we consider only those whose letters are in lexigraphical order (each character is smaller than the next character).

The coding system works like this:

• The words are arranged in the increasing order of their length.

• The words with the same length are arranged in lexicographical order (the order from the dictionary).

• We codify these words by their numbering, starting with a, as follows:

a - 1

b - 2

...

z - 26

ab - 27

...

az - 51

bc - 52

...

vwxyz - 83681

...

Specify for a given word if it can be codified according to this coding system. For the affirmative case specify its code.

Input
The only line contains a word. There are some constraints:

• The word is maximum 10 letters length

• The English alphabet has 26 characters.

Output
The output will contain the code of the given word, or 0 if the word can not be codified.

Sample Input
bf

Sample Output
55

Source
Romania OI 2002

Source Code
Problem: 1850		User: 14110103069
Memory: 688K		Time: 47MS
Language: G++		Result: Accepted

Source Code

#include <iostream>
#include<cstdio>
#include<cstring>
#include<map>
#include<set>
#include<queue>
#include<stack>
#include<cctype>
#include<vector>
#include<cmath>
#include<algorithm>
#define LL long long
#define uLL unsigned LL
#define uint unsigned int
using namespace std;
int C[28][28];

void solve(string s)
{
int len=s.length();
uint ans=0;
for(int i=1;i<len;i++)
{
ans+=C[26][i];
}
for(int i=0;i<len;i++)
{
if(i==0)
{
for(int j=97;j<s[i];j++)
ans+=C[26-(j-96)][len-1-i];
}
else
{
for(int j=s[i-1]+1;j<s[i];j++)
ans+=C[26-(j-96)][len-1-i];
}
}
cout<<ans+1<<endl;
}
int main()
{
string s;
memset(C,0,sizeof(C));
C[0][0]=1;
for(int i=1;i<28;i++)
{
C[i][0]=1;
for(int j=1;j<=i;j++)
{
C[i][j]=C[i-1][j-1]+C[i-1][j];
}
}
int len;
bool flag;
while(cin>>s)
{
flag=1;
len=s.length();
for(int i=0;i<len-1;i++)
{
if(s[i]>=s[i+1])
{
flag=0;
cout<<"0\n";
break;
}
}
if(flag)
solve(s);
}
return 0;
}


换为朴素表达:

Source Code
Problem: 1850		User: 14110103069
Memory: 680K		Time: 0MS
Language: G++		Result: Accepted

Source Code

#include <iostream>
#include<cstdio>
#include<cstring>
#include<map>
#include<set>
#include<queue>
#include<stack>
#include<cctype>
#include<vector>
#include<cmath>
#include<algorithm>
#define LL long long
#define uLL unsigned LL
#define uint unsigned int
using namespace std;
LL C[28][28];

void solve(char *s)
{
int len=strlen(s);
LL ans=0;
for(int i=1;i<len;i++)
{
ans+=C[26][i];
}
for(int i=0;i<len;i++)
{
if(i==0)
{
for(int j=97;j<s[i];j++)
ans+=C[26-(j-96)][len-1-i];
}
else
{
for(int j=s[i-1]+1;j<s[i];j++)
ans+=C[26-(j-96)][len-1-i];
}
}
cout<<ans+1<<endl;
}
int main()
{
char  s[32];
memset(C,0,sizeof(C));
C[0][0]=1;
for(int i=1;i<28;i++)
{
C[i][0]=1;
for(int j=1;j<=i;j++)
{
C[i][j]=C[i-1][j-1]+C[i-1][j];
}
}
bool flag;
int len;
while(cin>>s)
{
flag=1;
len=strlen(s);
for(int i=0;i<len-1;i++)
{
if(s[i]>=s[i+1])
{
flag=0;
cout<<"0\n";
break;
}
}
if(flag)
solve(s);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: