您的位置:首页 > Web前端 > JavaScript

hdoj2680 Choose the best route(dijstra)

2015-08-19 20:04 549 查看


Choose the best route

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 10670 Accepted Submission(s): 3443



Problem Description

One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take.
You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.



Input

There are several test cases.

Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands
for the bus station that near Kiki’s friend’s home.

Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .

Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.



Output

The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.



Sample Input

5 8 5
1 2 2
1 5 3
1 3 4
2 4 7
2 5 6
2 3 5
3 5 1
4 5 1
2
2 3
4 3 4
1 2 3
1 3 4
2 3 2
1
1




Sample Output

1
-1
</pre><pre name="code" class="cpp">
</pre><pre name="code" class="cpp">
<pre name="code" class="cpp">#include<stdio.h>
#define INF 0x6ffffff
#include<string.h>
#include<algorithm>
using namespace std;
int cost[1101][1101];
int dis[1101];
int used[1101];
int n;
void dij(int s)
{
	int i;
for( i=1;i<=n;i++)
{
	dis[i]=INF;
	used[i]=false;
}
	dis[s]=0;
	while(true)
	{
		int v=-1;
		for( i=1;i<=n;i++)
		{
			if(used[i]==0&&(v==-1||dis[v]>dis[i]))
			v=i;
		}
		if(v==-1)
		break;
		used[v]=true;
		for(i=1;i<=n;i++)
		dis[i]=min(dis[i],dis[v]+cost[v][i]);
	}
}

int main()
{
	int m,s,a,b,c,i,j,x,t;
	while(~scanf("%d%d%d",&n,&m,&s))
	{
		memset(dis,0,sizeof(0));
		for(i=1;i<=n;i++)
		for(j=1;j<=n;j++)
		{
			if(i==j)
			cost[i][j]=0;//相同车站距离为0 
			else
			cost[i][j]=INF;
		}
		for(i=0;i<m;i++)
		{
			scanf("%d%d%d",&a,&b,&c);
			if(cost[b][a]>c)//防止重边 
			cost[b][a]=c;
		}
		scanf("%d",&t);//有几个起点  
		int min=INF;
		dij(s);//由于终点只有一个可以看作起点 
		for(i=0;i<t;i++)
		{
		scanf("%d",&x);
		if(dis[x]<=min)//求出距离最小值 
		min=dis[x];
		}
		if(min!=INF)//如果都是INF则输出-1 
		printf("%d\n",min);
		else
		printf("-1\n");
		}
		return 0;
}





                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: