您的位置:首页 > 其它

UVA 562 - Dividing coins

2015-08-19 19:41 405 查看
UVA 562 - Dividing coins

It’s commonly known that the Dutch have invented copper-wire. Two Dutch men were fighting over a nickel, which was made of copper. They were both so eager to get it and the fighting was so fierce, they stretched the coin to great length and thus created copper-wire.

Not commonly known is that the fighting started, after the two Dutch tried to divide a bag with coins between the two of them. The contents of the bag appeared not to be equally divisible. The Dutch of the past couldn’t stand the fact that a division should favour one of them and they always wanted a fair share to the very last cent. Nowadays fighting over a single cent will not be seen anymore, but being capable of making an equal division as fair as possible is something that will remain important forever…

That’s what this whole problem is about. Not everyone is capable of seeing instantly what’s the most fair division of a bag of coins between two persons. Your help is asked to solve this problem.

Given a bag with a maximum of 100 coins, determine the most fair division between two persons. This means that the difference between the amount each person obtains should be minimised. The value of a coin varies from 1 cent to 500 cents. It’s not allowed to split a single coin.

Input

A line with the number of problems n, followed by n times:

a line with a non negative integer m (m≤100m \le 100) indicating the number of coins in the bag

a line with m numbers separated by one space, each number indicates the value of a coin.

Output

The output consists of n lines. Each line contains the minimal positive difference between the amount the two persons obtain when they divide the coins from the corresponding bag.

Sample Input

2

3

2 3 5

4

1 2 4 6

Sample Output

0

1

01背包问题

思路:等价转化。平分总额(容量)为sum的包相当于用那些硬币去装一个容量为sum/2的包(剩下的硬币就是另一个包),这不就是0-1背包了么~

[code]#include<iostream>
#include <cstdio>
#include <string.h>
#include <algorithm>
#include <math.h>
using namespace std;
int dp[50005];
int main()
{
#ifndef ONLINE_JUDGE
    freopen("1.txt", "r", stdin);
#endif
    int n, m, i, j, value[110], sum, a , b;
    cin >> n;
    while(n--)
    {
        scanf("%d", &m);
        sum = 0;
        for(i = 1; i <= m; i++)
        {
            scanf("%d", &value[i]);
            sum += value[i];
        }
        a = sum/2;
        memset(dp, 0, sizeof(dp));
        for (i = 1; i <= m; i++)
        {
            for (j = a; j >= value[i]; j--)
            {
                dp[j] = max(dp[j], dp[j-value[i]]+value[i]);
            }
        }
        cout << sum-2*dp[a] << endl;
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: