您的位置:首页 > 其它

poj1734Sightseeing Trip

2015-08-19 18:33 316 查看
http://poj.org/problem?id=1734

Description

There is a travel agency in Adelton town on Zanzibar island. It has decided to offer its clients, besides many other attractions, sightseeing the town. To earn as much as possible from this attraction, the agency has accepted a shrewd decision: it is necessary to find the shortest route which begins and ends at the same place. Your task is to write a program which finds such a route.

In the town there are N crossing points numbered from 1 to N and M two-way roads numbered from 1 to M. Two crossing points can be connected by multiple roads, but no road connects a crossing point with itself. Each sightseeing route is a sequence of road numbers y_1, ..., y_k, k>2. The road y_i (1<=i<=k-1) connects crossing points x_i and x_{i+1}, the road y_k connects crossing points x_k and x_1. All the numbers x_1,...,x_k should be different.The length of the sightseeing route is the sum of the lengths of all roads on the sightseeing route, i.e. L(y_1)+L(y_2)+...+L(y_k) where L(y_i) is the length of the road y_i (1<=i<=k). Your program has to find such a sightseeing route, the length of which is minimal, or to specify that it is not possible,because there is no sightseeing route in the town.
Input

The first line of input contains two positive integers: the number of crossing points N<=100 and the number of roads M<=10000. Each of the next M lines describes one road. It contains 3 positive integers: the number of its first crossing point, the number of the second one, and the length of the road (a positive integer less than 500).
Output

There is only one line in output. It contains either a string 'No solution.' in case there isn't any sightseeing route, or it contains the numbers of all crossing points on the shortest sightseeing route in the order how to pass them (i.e. the numbers x_1 to x_k from our definition of a sightseeing route), separated by single spaces. If there are multiple sightseeing routes of the minimal length, you can output any one of them.
Sample Input

5 7
1 4 1
1 3 300
3 1 10
1 2 16
2 3 100
2 5 15
5 3 20
Sample Output

1 3 5 2


给出一张无向图,求一个最小环并输出路径。

包含点 i 和点 j 的最小环,我们可以看成是 i 到 j 之间的最短路和次短路的组合,通过 floyd 可求任意两点之间的最短距离,那么我们只要找到最短路径外的一条最短路来保证 i 和 j 之间可达即可。在做 floyd 循环的同时,我们以 环权值 最小(最短路权值+次短路权值=最小环权值)为标准,一直更新每个点的前驱,也就是记录 i 到 j 的最短路径,以及,能够松弛 i 和 j 的点 k (k 不在 i 到 j 的最短路径中)中代价最小的那个(也就是 i 到 j 之间的次短路),然后按环的自然顺序输出即可。

#include <iostream>
#include<cstdio>
#include<cstring>
#include<math.h>
using namespace std;

const int N = 101;
const int INF = 0x7ffffff;
int mat

,dist

,pre

,path
,n;

int main()
{
int i,j,k,m,a,b,c;
int num;
while(~scanf("%d%d",&n,&m))
{
for(i=1;i<=n;i++)
{
for(j=1;j<=n;j++)
{
mat[i][j]=dist[i][j]=INF;
pre[i][j]=i;
}
}
while(m--)
{
scanf("%d%d%d",&a,&b,&c);
mat[a][b]=mat[b][a]=dist[a][b]=dist[b][a]=min(mat[a][b],c);
}

int min=INF;
for(k=1;k<=n;k++)
{//最短路径外一点将最短路首尾链接,那么就得到一个最小环
for(i=1;i<k;i++)
{
for(j=i+1;j<k;j++)
{
//求最小环不能用两点间最短路松弛,因为(i,k)之间的最短路,(k,j)之间的最短路可能有重合的部分
//所以mat[][]其实是不更新的,这里和单纯的floyd最短路不一样
//dist[i][j]保存的是 i 到 j 的最短路权值和
int tmp=dist[i][j]+mat[i][k]+mat[k][j];//这里 k 分别和 i 还有 j 在mat中直接相连
if(tmp<min)
{
min=tmp;
num=0;
int p=j;
while(p!=i)
{//回溯
path[num++]=p;
p=pre[i][p];//pre[i][j]表示 i 到 j 最短路径上 j 前面的一个点
}
path[num++]=i;
path[num++]=k;
}
}
}
for(i=1;i<=n;i++)
{
for(j=1;j<=n;j++)
{
if(dist[i][j]>dist[i][k]+dist[k][j])
{
dist[i][j]=dist[i][k]+dist[k][j];//dist[][]保存两点间最短距离
pre[i][j]=pre[k][j];
}
}
}
}
if(min==INF)puts("No solution.");
else{
printf("%d",path[0]);
for(i=1;i<num;i++)
printf(" %d",path[i]);
puts("");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: