您的位置:首页 > 产品设计 > UI/UE

Longest Ordered Subsequence(POJ--2533

2015-08-19 16:18 666 查看
Description
A numeric sequence of ai is ordered if a1 < a2 < ... < aN.
Let the subsequence of the given numeric sequence (a1, a2, ..., aN) be any sequence (ai1, ai2, ..., aiK),
where 1 <= i1 < i2 < ... < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of
length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.
Input
The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the
range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000
Output
Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.
题意:输入n个数,求这n个数的最长上升子序列的长度。
思路:用数组dp[i]来记录以第i个数为上升子序列的最后一个数的长度,枚举这n个数,只要当前这个数前边有比它小的数,就让当前这个数的dp与比它小的那个数的dp+1比较,哪个大当前数的dp就等于哪个。(注意:如果前边没有比当前这个数小的数,那么当前这个数的dp就等于1,它本身也是一个上升子序列。PS:上升子序列是严格的递增序列。)
Sample Input
7
1 7 3 5 9 4 8

Sample Output
4

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <queue>
#define INF 0x3f3f3f3f
using namespace std;
int dp[1200],a[1200];
int main()
{
//freopen("lalala.text","r",stdin);
int n;
scanf("%d",&n);
for(int i=0; i<n; i++)
scanf("%d",&a[i]);
memset(dp,0,sizeof(dp));
dp[0]=1;
for(int i=1; i<n; i++)
{
int flag=1;
for(int j=i-1; j>=0; j--)
{
if(a[i]>a[j])
{
flag=0;      //标记当前数之前有数小于它
dp[i]=max(dp[i],dp[j]+1);
}
}
if(flag)       //如果当前数之前没有数小于它,则它本身相当于一个上升子序列,已其为结尾的上升子序列的长度为1
dp[i]=1;
}
int mm=-1;               //最长上升子序列的长度并不一定是dp[n-1],要枚举所有的dp,然后就最大即最长
for(int i=0; i<n; i++)
if(dp[i]>mm)
mm=dp[i];
printf("%d\n",mm);
return 0;
}<strong>
</strong>
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: