您的位置:首页 > 其它

越狱计划之背包初步--多重背包

2015-08-19 15:52 302 查看
/*下午继续阅读了dd大神发布背包九讲之中的完全和多重背包,收获很大,讲解了由01背包变化延伸至完全背包和多重背包的重要基本思想
和状态更改的由来。和01背包不同,完全背包和多重背包都可以转化为01背包思考。感谢dd大神为众多ACMer提供整理这珍贵的资料。*/


从多重背包开始,多重背包囊括前面两种背包的状态。基础问题为:

有 N 种物品和一个容量为 V 的背包。第 i 种物品最多有 n[i] 件可用,每件费用是 c[i] ,价值是 w[i] 。求解将哪些物品装入背包可使这些物品的费用总和不超过背包容量,且价值总和最大.

基本解决算法这题目和完全背包问题很类似。基本的方程只需将完全背包问题的方程略微一改即可,因为对于第 i 种物品有 n[i]+1 种策略:取 0 件,取 1 件 . . . 取 n[i] 件。令 dp[i][v] 表示前 i 种物品恰放入一个容量为 v 的背包的最大权值,则有状态转移方程:

dp[i][v] = max{dp[i-1][v-k*c[i]]+k*w[i]} (0<=k<=n[i])


用POJ1129做一下解题报告顺便理清一下我自己的思路

Cash Machine

Description
A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination
Dk the machine has a supply of nk bills. For example,

N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10

means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each.

Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine.

Notes:

@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc.

Input
The program input is from standard input. Each data set in the input stands for a particular transaction and has the format:

cash N n1 D1 n2 D2 ... nN DN

where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers
in the input. The input data are correct.

Output
For each set of data the program prints the result to the standard output on a separate line as shown in the examples below.

Sample Input
735 3  4 125  6 5  3 350
633 4  500 30  6 100  1 5  0 1
735 0
0 3  10 100  10 50  10 10

Sample Output
735
630
0
0

Hint
The first data set designates a transaction where the amount of cash requested is @735. The machine contains 3 bill denominations: 4 bills of @125, 6 bills of @5, and 3 bills of @350. The machine can deliver the exact amount of
requested cash.

In the second case the bill supply of the machine does not fit the exact amount of cash requested. The maximum cash that can be delivered is @630. Notice that there can be several possibilities to combine the bills in the machine for matching the delivered
cash.

In the third case the machine is empty and no cash is delivered. In the fourth case the amount of cash requested is @0 and, therefore, the machine delivers no cash.
Source
Southeastern Europe 2002

题目大意: 有N种货币,每种货币的数量和价值是确定的,求怎样用这N种货币组合出max(x)<=cash.

问题思考: 货币的种类上限,每种货币的数量上限,为经典多重背包问题。

此时我们需要将基本的思路进行优化,优化思路及方法:

将第 i 种物品分成若干件物品,其中每件物品有一个系数,这件物品的费用和价值均是原来的费用和价值乘以这个系数。使这些系数分别为1,2,4,. . . ,2^(k−1) ,n[i] − 2^k + 1 ,且 k 是满足 n[i] − 2^k + 1 > 0 的最大整数。例如,如果 n[i] 为 13 ,就将这种物品分成系数分别为 1,2,4,6 的四件物品。

给出背包九讲中多重背包的伪代码:

MultiplePack(cost, weight, amount)
if cost × amount >= V
then
CompletePack(cost, weight)
return
int k <- 1 while k < amount
do
ZeroOnePack(k × cost, k × weight)
amount ← amount − k
k ← k × 2
ZeroOnePack(amount × cost, amount × weight)


所以根据伪代码,可以得到这道题目的解题思路及代码如下:

#include <algorithm>
#include <iostream>
#include <cstring>
#include <string>
#include <vector>
#include <cstdio>
#include <queue>
#include <stack>
#include <cmath>
#include <map>
#include <set>

using namespace std;

const int INF = 0x3f3f3f3f;
const int M = 100001;

int n,v,dp[M];
struct node
{
int n,c;//n:物品数量 c:单个物品价值
}N[11];

void ZeroOnePack(int c)//01背包
{
for(int i=v;i>=c;i--)
{
if(dp[i] < dp[i-c]+c)
dp[i] = dp[i-c] + c;
}
}
void CompletePack(int c)//完全背包
{
for(int i=c;i<=v;i++)
{
if(dp[i] < dp[i-c]+c)
dp[i] = dp[i-c]+c;
}
}
void MultiplePack(int c,int ant)//多重背包
{
if(c * ant >= v)
{
CompletePack(c);
}
else
{
int k = 1;
while(k < ant)
{
ZeroOnePack(c * k);
ant-=k;
k*=2;
}
ZeroOnePack(c*ant);
}
}

int main()
{
while(~scanf("%d %d",&v,&n))
{
for(int i=1;i<=n;i++)
{
scanf("%d %d",&N[i].n,&N[i].c);
}
memset(dp,0,sizeof(dp));
for(int i=1;i<=n;i++)
{
MultiplePack(N[i].c,N[i].n);
}
printf("%d\n",dp[v]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: