您的位置:首页 > 编程语言 > Lua

UVA 327 -Evaluating Simple C Expressions(栈)

2015-08-19 14:44 525 查看
Evaluating Simple C Expressions

The task in this problem is to evaluate a sequence of simple C expressions, buy you need not know C to solve the problem! Each of the expressions will appear on a line by itself and will contain no more than 110 characters. The expressions to be evaluated will contain only simple integer variables and a limited set of operators; there will be no constants in the expressions. There are 26 variables which may appear in our simple expressions, namely those with the names a through z (lower-case letters only). At the beginning of evaluation of each expression, these 26 variables will have the integer values 1 through 26, respectively (that is, a = 1, b = 2, ..., n = 14, o = 15, ...,z = 26). Each variable will appear at most once in an expression, and many variables may not be used at all.

The operators that may appear in expressions include the binary (two-operand) + and -, with the usual interpretation. Thus the expressiona + c - d + b has the value 2 (computed as 1 + 3 - 4 + 2). The only other operators that may appear in expressions are ++ and --. These are unary (one-operand) operators, and may appear before or after any variable. When the ++ operator appears before a variable, that variable's value is incremented (by one) before the variable's value is used in determining the value of the entire expression. Thus the value of the expression ++c - b is 2, with c being incremented to 4 prior to evaluating the entire expression. When the ++ operator appears after a variable, that variable is incremented (again, by one) after its value is used to determine the value of the entire expression. Thus the value of the expression c++ - b is 1, but c is incremented after the complete expression is evaluated; its value will still be 4. The -- operator can also be used before or after a variable to decrement (by one) the variable; its placement before or after the variable has the same significance as for the ++ operator. Thus the expression --c + b-- has the value 4, with variables c and b having the values 2 and 1 following the evaluation of the expression.

Here's another, more algorithmic, approach to explaining the ++ and -- operators. We'll consider only the ++ operator, for brevity:

Identify each variable that has a ++ operator before it. Write a simple assignment statement that increments the value of each such variable, and remove the ++ operator from before that variable in the expression.

In a similar manner, identify each variable that has a ++ operator after it. Write a simple assignment statement that increments the value of each of these, and remove the ++ operator from after that variable in the expression.

Now the expression has no ++ operators before or after any variables. Write the statement that evaluates the remaining expression after those statements written in step 1, and before those written in step 2.

Execute the statements generated in step 1, then those generated in step 3, and finally the one generated in step 2, in that order.

Using this approach, evaluating the expression ++a + b++ is equivalent to computing

a = a + 1 (from step 1 of the algorithm)

expression = a + b (from step 3)

b = b + 1 (from step 2)

where expression would receive the value of the complete expression.

Input and Output

Your program is to read expressions, one per line, until the end of the file is reached. Display each expression exactly as it was read, then display the value of the entire expression, and on separate lines, the value of each variable after the expression was evaluated. Do not display the value of variables that were not used in the expression. The samples shown below illustrate the desired exact output format.

Blanks are to be ignored in evaluating expressions, and you are assured that ambiguous expressions like a+++b (ambiguous because it could be treated as a++ + b or a + ++b) will not appear in the input. Likewise, ++ or -- operators will never appear both before and after a single variable. Thus expressions like ++a++ will not be in the input data.

Sample Input

a + b
b - z
a+b--+c++
c+f--+--a
f-- + c-- + d-++e


Sample Output

Expression: a + b
value = 3
a = 1
b = 2
Expression: b - z
value = -24
b = 2
z = 26
Expression: a+b--+c++
value = 6
a = 1
b = 1
c = 4
Expression: c+f--+--a
value = 9
a = 0
c = 3
f = 5
Expression:    f-- + c-- + d-++e
value = 7
c = 2
d = 4
e = 6
f = 5

题意:给一行字符串,代表一个表达式,表达式中只包含+,-,前置++,后置++,前置--,后置--,而且不会有违法的表达式出现,a,b,c,d.....初始时代表的值分别是1,2,3,4......
计算每个表达式的值,并且按照字典序大小输出每个出现在表达式中的字母的最终值的大小。

解析:使用栈这一数据结构,这题最好手写,不要用STL中的stack,扫一遍字符串,如果是'+',先判断他是否是某个数的后置++,直接找栈中元素的rear和rear-1是否分别是'+'和一个字母
(rear越界则不可能),再把那个字母的权值加1,弹出最顶上的元素。如果不存在这种情况,则加入到栈中,'-'跟'+'的操作一样,如果是字母,则先判断他是否有前置++或前置--,直接查找
栈中元素,如果rear和rear-1都是'+',则权值加1,并弹出栈中两个元素,答案加上该字母的权值(还要判断栈中rear是+(或没有)还是- ),最后按照格式输出,格式比较麻烦,自己要注意。

代码如下:

#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#include<set>
#include<map>
#include<queue>
#include<vector>
#include<iterator>
#include<utility>
#include<sstream>
#include<iostream>
#include<cmath>
#include<stack>
using namespace std;
const int INF=1000000007;
const double eps=0.00000001;
int digit[27];                        // 保存相应字母的权值
bool have[27];                        // 判断某个字母是否在字符串中
string S;
int GetVal(char c){ return c-'a'+1; }     // 得到这个字母的大小
vector<char> save;
char SK[10005];                // 栈
void solve()
{
for(int i=1;i<=26;i++)  digit[i]=i;
memset(have,false,sizeof(have));
int ret=0;                       // 答案
int rear=0;                      // 栈指针
int len=save.size();
for(int i=0;i<len;i++)
{
if(save[i]=='+')
{
if(rear>1&&SK[rear]=='+'&&islower(SK[rear-1]))   //是否为后置++
{
digit[GetVal(SK[rear-1])]++;
rear--;
}
else SK[++rear]='+';                 // 否则加入栈
}
else if(save[i]=='-')
{
if(rear>1&&SK[rear]=='-'&&islower(SK[rear-1]))   // 是否为后置--
{
digit[GetVal(SK[rear-1])]--;
rear--;
}
else  SK[++rear]='-';
}
else
{
int id=GetVal(save[i]);
have[id]=true;                     // 标记
if(rear>1&&SK[rear]=='+'&&SK[rear-1]=='+')        // 前置++
{
digit[id]++;
rear--;
rear--;
}
else if(rear>1&&SK[rear]=='-'&&SK[rear-1]=='-')    // 前置--
{
digit[id]--;
rear--;
rear--;
}

if(rear==0||SK[rear]=='+')  ret+=digit[id];
else  ret-=digit[id];
SK[++rear]=save[i];
}
}
printf("Expression: ");
cout<<S<<endl;
printf("    value = %d\n",ret);
for(int i=1;i<=26;i++) if(have[i]) printf("    %c = %d\n",i-1+'a',digit[i]);
}
int main()
{
while(getline(cin,S))
{
save.clear();
for(int i=0;i<S.size();i++)  if(S[i]!=' ') save.push_back(S[i]);
solve();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: