您的位置:首页 > 其它

POJ 3259 Wormholes(spfa判负环)

2015-08-19 11:01 405 查看

Wormholes

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W

Lines 2..M+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.

Lines M+2..M+W+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.
Output

Lines 1..F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).
Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle
1->2->3->1, arriving back at his starting location 1 second
before he leaves. He could start from anywhere on the cycle to
accomplish this.

#include<cstdio>
#include<queue>
#include<cstring>
#include<algorithm>
using namespace std;

const int maxn=550;
const int maxm=2555;
const int inf=0x3f3f3f3f;
int G[maxn][maxn];
bool vis[maxn];
int used[maxn];
int d[maxn];
int cnt;
int m,n1,n2;

bool spfa(int s)
{
queue<int>q;
memset(vis,0,sizeof(vis));
memset(d,inf,sizeof(d));
memset(used,0,sizeof(used));
d[s]=0;
q.push(s);
vis[s]=1;
used[s]++;
while(!q.empty())
{
int u=q.front();
q.pop();
vis[u]=0;
for(int i=1;i<=m;i++)
{
if(d[i]>d[u]+G[u][i])
{
d[i]=d[u]+G[u][i];
if(!vis[i])
{
if(used[i]>=maxn)
return true;
q.push(i);
vis[i]=1;
used[i]++;
}
}
}
}
return false;
}

int main()
{
int t,u,v,w;
scanf("%d",&t);
while(t--)
{
memset(G,inf,sizeof(G));
scanf("%d%d%d",&m,&n1,&n2);
for(int i=0;i<n1;i++)
{
scanf("%d%d%d",&u,&v,&w);
G[u][v]=G[v][u]=min(G[u][v],w);
}
for(int i=0;i<n2;i++)
{
scanf("%d%d%d",&u,&v,&w);
G[u][v]=min(G[u][v],-w);
}
int ans=spfa(1);
if(ans)
printf("YES\n");
else
printf("NO\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: