您的位置:首页 > 其它

POJ 1012 Joseph

2015-08-19 09:17 369 查看
Language:
Joseph

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 50325Accepted: 19130
Description
The Joseph's problem is notoriously known. For those who are not familiar with the original problem: from among n people, numbered 1, 2, . . ., n, standing in circle every mth is going to be executed and only the life of the last
remaining person will be saved. Joseph was smart enough to choose the position of the last remaining person, thus saving his life to give us the message about the incident. For example when n = 6 and m = 5 then the people will be executed in the order 5, 4,
6, 2, 3 and 1 will be saved.

Suppose that there are k good guys and k bad guys. In the circle the first k are good guys and the last k bad guys. You have to determine such minimal m that all the bad guys will be executed before the first good guy.

Input
The input file consists of separate lines containing k. The last line in the input file contains 0. You can suppose that 0 < k < 14.

Output
The output file will consist of separate lines containing m corresponding to k in the input file.

Sample Input
3
4
0

Sample Output
5
30

Source
Central Europe 1995

ACcode:

#include <iostream>
#include <cstdio>
using namespace std;
int main(){
    int a[14],i,j,k,temp;
    for(i=1;i<14;++i){
        for(j=i+1;;j++){
            for(k=0,temp=0;k<i;k++){
                temp=(temp+j-1)%(2*i-k);
                if(temp<i)break;
            }
            if(i==k){
                a[i]=j;
                break;
            }
        }
    }
    while(scanf("%d",&i)!=EOF&&i)printf("%d\n",a[i]);
    return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: