您的位置:首页 > 其它

AreYouBusy

2015-08-18 20:54 183 查看
AreYouBusy

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 3434 Accepted Submission(s): 1334

Problem Description

Happy New Term!

As having become a junior, xiaoA recognizes that there is not much time for her to AC problems, because there are some other things for her to do, which makes her nearly mad.

What’s more, her boss tells her that for some sets of duties, she must choose at least one job to do, but for some sets of things, she can only choose at most one to do, which is meaningless to the boss. And for others, she can do of her will. We just define the things that she can choose as “jobs”. A job takes time , and gives xiaoA some points of happiness (which means that she is always willing to do the jobs).So can you choose the best sets of them to give her the maximum points of happiness and also to be a good junior(which means that she should follow the boss’s advice)?

Input

There are several test cases, each test case begins with two integers n and T (0<=n,T<=100) , n sets of jobs for you to choose and T minutes for her to do them. Follows are n sets of description, each of which starts with two integers m and s (0m<=100), there are m jobs in this set , and the set type is s, (0 stands for the sets that should choose at least 1 job to do, 1 for the sets that should choose at most 1 , and 2 for the one you can choose freely).then m pairs of integers ci,gi follows (0<=ci,gi<=100), means the ith job cost ci minutes to finish and gi points of happiness can be gained by finishing it. One job can be done only once.

Output

One line for each test case contains the maximum points of happiness we can choose from all jobs .if she can’t finish what her boss want, just output -1 .

Sample Input

3 3

2 1

2 5

3 8

2 0

1 0

2 1

3 2

4 3

2 1

1 1

3 4

2 1

2 5

3 8

2 0

1 1

2 8

3 2

4 4

2 1

1 1

1 1

1 0

2 1

5 3

2 0

1 0

2 1

2 0

2 2

1 1

2 0

3 2

2 1

2 1

1 5

2 8

3 2

3 8

4 9

5 10

Sample Output

5

13

-1

-1

Author

hphp

Source

2010 ACM-ICPC Multi-University Training Contest(10)——Host by HEU

Recommend

zhouzeyong

混合背包

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <queue>
#include <algorithm>

using namespace std;

typedef long long LL;

typedef pair<int,int>p;

const int INF = 0x3f3f3f3f;

int Dp[110][110];//记录执行i个任务是不同时间所获得的最大快乐

int n,T;

int m,s;

int w[110],v[110];

int main()
{
while(~scanf("%d %d",&n,&T))
{
memset(Dp,-1,sizeof(Dp));

memset(Dp[0],0,sizeof(Dp[0]));

for(int i=1; i<=n; i++)
{
scanf("%d %d",&m,&s);
for(int j=1; j<=m; j++)
{
scanf("%d %d",&v[j],&w[j]);
}
if(s==0)
{
for(int j=1; j<=m; j++)
{

for(int k=T; k>=v[j]; k--)
{
if(Dp[i][k-v[j]]!=-1)//这一状态是建立放一件物品的基础上,01背包形式,可以选多个物品
{
Dp[i][k]=max(Dp[i][k],Dp[i][k-v[j]]+w[j]);
}
if(Dp[i-1][k-v[j]]!=-1)//由上一状态转化而来,保证至少有一个
{
Dp[i][k]=max(Dp[i][k],Dp[i-1][k-v[j]]+w[j]);
}
}
}
}
else if(s==1)
{
for(int k=0; k<=T; k++)//将上一状态转移到这个状态
{
Dp[i][k]=Dp[i-1][k];
}
for(int j=1; j<=m; j++)
{
for(int k=T; k>=v[j];k--)
{
if(Dp[i-1][k-v[j]]!=-1)//至多一个
{
Dp[i][k]=max(Dp[i][k],Dp[i-1][k-v[j]]+w[j]);
}
}
}
}
else if(s==2)
{
for(int k=0; k<=T; k++)
{
Dp[i][k]=Dp[i-1][k];
}
for(int j=1;j<=m;j++)//01背包
{
for(int k=T;k>=v[j];k--)
{
if(Dp[i][k-v[j]]!=-1)
{
Dp[i][k]=max(Dp[i][k],Dp[i][k-v[j]]+w[j]);
}
}
}

}
}
printf("%d\n",Dp
[T]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: