您的位置:首页 > 其它

hdu 2647

2015-08-18 17:08 169 查看
Description

Dandelion's uncle is a boss of a factory. As the spring festival is coming , he wants to distribute rewards to his workers. Now he has a trouble about how to distribute the rewards.

The workers will compare their rewards ,and some one may have demands of the distributing of rewards ,just like a's reward should more than b's.Dandelion's unclue wants to fulfill all the demands, of course ,he wants to use the least money.Every work's reward
will be at least 888 , because it's a lucky number.

Input

One line with two integers n and m ,stands for the number of works and the number of demands .(n<=10000,m<=20000)

then m lines ,each line contains two integers a and b ,stands for a's reward should be more than b's.

Output

For every case ,print the least money dandelion 's uncle needs to distribute .If it's impossible to fulfill all the works' demands ,print -1.

Sample Input

2 1
1 2
2 2
1 2
2 1


Sample Output

1777
-1


#include <stdio.h>
#include <string.h>
#define MAXN 10010
#define MAXM 20010
int n,m;
int first[MAXN],in[MAXN];
int u[MAXM],v[MAXM],next[MAXM];
bool vis[MAXN];

void input()
{
int i,a,b,f;
memset(first,-1,sizeof(first));
memset(in,0,sizeof(in));
for(f=1,i=0; i<m; i++)
{
scanf("%d%d",&a,&b);
u[i]=b; v[i]=a;
in[v[i]]++;
next[i]=first[u[i]];
first[u[i]]=i;
}
}

int topsort()
{
int sum;
int temp[MAXN];
int i,j,k,c,t;
memset(vis,0,sizeof(vis));
c=0;  sum=0; j=0;
//j表示的是层数,第一层是0,所以工资为888,依次是889.890
//c表示已经有多少个点纳入拓扑序列,c=n则是dag
//sum是最后的答案
while(1)
{
k=0;
for(i=1; i<=n; i++)  //对应n个顶点
if(!vis[i] && in[i]==0)
{
vis[i]=1;  c++;  sum+=(888+j);
temp[k++]=i;  //记录下当前这一轮找到的入度为0的顶点
}
if(c>=n)  return sum;
if(!k)    return -1;
//如果在这次构建结束后,扫描所有顶点都找不到入度为0那说明存在环
for(i=0; i<k; i++)
//对应temp数组,这一轮找到的入度为0的顶点,要遍历它的邻接表,使对应的弧头入度减1
{
t=temp[i];  //记录弧尾顶点标号
t=first[t];  //记录这个顶点的第一条弧的编号
while(t!=-1)
{
in[v[t]]--;
t=next[t];
}
}

j++;
}
}

int main()
{
int ans;
while(scanf("%d%d",&n,&m)!=EOF)
{
input();
printf("%d\n",ans=topsort());
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: