您的位置:首页 > 其它

HDU 5399 Too Simple

2015-08-18 17:06 225 查看
Problem Description

Rhason Cheung had a simple problem, and asked Teacher Mai for help. But Teacher Mai thought this problem was too simple, sometimes naive. So she ask you for help.

Teacher Mai has m functions f1,f2,⋯,fm:{1,2,⋯,n}→{1,2,⋯,n}(that
means for all x∈{1,2,⋯,n},f(x)∈{1,2,⋯,n}).
But Rhason only knows some of these functions, and others are unknown.

She wants to know how many different function series f1,f2,⋯,fm there
are that for every i(1≤i≤n),f1(f2(⋯fm(i)))=i.
Two function series f1,f2,⋯,fm and g1,g2,⋯,gm are
considered different if and only if there exist i(1≤i≤m),j(1≤j≤n),fi(j)≠gi(j).



Input

For each test case, the first lines contains two numbers n,m(1≤n,m≤100).

The following are m lines.
In i-th
line, there is one number −1 or n space-separated
numbers.

If there is only one number −1,
the function fi is
unknown. Otherwise the j-th
number in the i-th
line means fi(j).



Output

For each test case print the answer modulo 109+7.



Sample Input

3 3
1 2 3
-1
3 2 1




Sample Output

1
HintThe order in the function series is determined. What she can do is to assign the values to the unknown functions. 
这题其实很简单,对于多于两个-1的情况不管之前那个怎么选,只要最后一个固定就可以保证,所以答案就是(n!)^(m-1)   m是-1的个数
不过此题坑比较多,要注意判断
#pragma comment(linker, "/STACK:1024000000,1024000000") 
#include<set>
#include<map>
#include<queue>
#include<stack>
#include<cmath>
#include<cstdio>
#include<vector>
#include<string>
#include<cstring>
#include<algorithm>
#include<functional>
using namespace std;
typedef long long LL;
const LL base = 1e9 + 7;
const int maxn = 105;
LL T, n, m, f[maxn], a[maxn][maxn];

inline void read(int &x)
{
    char ch;
    while ((ch = getchar())<'0' || ch>'9');
    x = ch - '0';
    while ((ch = getchar()) >= '0' && ch <= '9') x = x * 10 + ch - '0';
}

int main()
{
    //read(T);
    for (int i = f[0] = 1; i <= 100; i++) f[i] = f[i - 1] * i % base;
    while (scanf("%I64d%I64d", &n, &m) != EOF)
    {
        LL tot = 0, ans = 1;
        for (int i = 1; i <= m; i++)
        {
            scanf("%I64d", &a[i][1]);
            if (a[i][1] == -1) tot++;
            else for (int j = 2; j <= n; j++)
            {
                scanf("%I64d", &a[i][j]);
                for (int k = j - 1; k; k--) if (a[i][j] == a[i][k]) ans = 0;
            }
        }
        for (int i = 1; i < tot; i++) ans = ans * f
 % base;
        if (tot == 0)
        {
            for (int i = 1; i <= n; i++) a[0][i] = i;
            for (int i = m; i; i--)
                for (int j = 1; j <= n; j++) a[0][j] = a[i][a[0][j]];
            for (int i = 1; i <= n; i++) if (a[0][i] != i) ans = 0;
        }
        printf("%I64d\n", ans);
    }
    return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: