您的位置:首页 > 其它

排序检索C - Where is the Marble?

2015-08-18 16:15 253 查看
Raju and Meena love to play with Marbles. They have got a lot of

marbles with numbers written on them. At the beginning, Raju would

place the marbles one after another in ascending order of the numbers

written on them. Then Meena would ask Raju to nd the rst marble

with a certain number. She would count 1...2...3. Raju gets one point

for correct answer, and Meena gets the point if Raju fails. After some

xed number of trials the game ends and the player with maximum

points wins. Today it's your chance to play as Raju. Being the smart

kid, you'd be taking the favor of a computer. But don't underestimate

Meena, she had written a program to keep track how much time you're

taking to give all the answers. So now you have to write a program,

which will help you in your role as Raju.

Input

There can be multiple test cases. Total no of test cases is less than 65. Each test case consists begins

with 2 integers:

N

the number of marbles and

Q

the number of queries Mina would make. The next

N

lines would contain the numbers written on the

N

marbles. These marble numbers will not come

in any particular order. Following

Q

lines will have

Q

queries. Be assured, none of the input numbers

are greater than 10000 and none of them are negative.

Input is terminated by a test case where

N

= 0 and

Q

= 0.

Output

For each test case output the serial number of the case.

For each of the queries, print one line of output. The format of this line will depend upon whether

or not the query number is written upon any of the marbles. The two different formats are described

below:



`

x

found at

y

', if the rst marble with number

x

was found at position

y

. Positions are numbered

1

;

2

;:::;N

.



`

x

not found

', if the marble with number

x

is not present.

Look at the output for sample input for details.

SampleInput

4 1

2

3

5

1

5

5 2

1

3

3

3

1

2

3

0 0

SampleOutput

CASE# 1:

5 found at 4

CASE# 2:

2 not found

3 found at 3

要找的数字在最下面

输入的几个数字在查找之前要先排序

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
int cmp(const void *a, const void *b){
return (*(int *)a- *(int *)b);
}

int main(){
int n, q, times = 1, qnum, nnum[10010];
while (scanf("%d%d", &n, &q) != EOF) {
if (n == 0 && q == 0)
break;
memset(nnum, 0, sizeof(nnum));
printf("CASE# %d:\n", times++);
for (int i = 0; i < n; i++)
scanf("%d", &nnum[i]);
qsort(nnum, n, sizeof(nnum[0]), cmp);
for (int i = 0; i < q; i++)  {
scanf("%d", &qnum);
int mark = 0, flag = 0;
for (int j = 0; j < n; j++)
if (qnum == nnum[j]) {
printf("%d found at %d\n", qnum, j + 1);
flag = 1;
break;
}
if (flag == 0)
printf("%d not found\n", qnum);
}
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: