您的位置:首页 > 其它

Eddy's research I

2015-08-18 15:16 465 查看
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 7687 Accepted Submission(s): 4674



[align=left]Problem Description[/align]
Eddy's interest is very extensive, recently he is interested in prime number. Eddy discover the all number owned can be divided into the multiply of prime number, but he can't write program, so Eddy has to ask intelligent you to help
him, he asks you to write a program which can do the number to divided into the multiply of prime number factor .

[align=left]Input[/align]
The input will contain a number 1 < x<= 65535 per line representing the number of elements of the set.

[align=left]Output[/align]
You have to print a line in the output for each entry with the answer to the previous question.

[align=left]Sample Input[/align]

11
9412


[align=left]Sample Output[/align]

11
2*2*13*181


#include<stdio.h>
int main()
{
int i,n;
while(scanf("%d",&n)!=EOF)
{
for(i=2;i<=n;i++)
{
while(n%i==0)
{
if(n/i==1)
printf("%d\n",i);
else printf("%d*",i);
n=n/i;
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: