您的位置:首页 > 其它

HDU 1013 Digital Roots

2015-08-18 12:15 411 查看
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1013

[align=left]Problem Description[/align]
The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are
summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process
must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

[align=left]Input[/align]
The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.

[align=left]Output[/align]
For each integer in the input, output its digital root on a separate line of the output.

[align=left]Sample Input[/align]

24
39
0


[align=left]Sample Output[/align]

6
3


题目大意:输出一个整数的各个位数之和,直到这个和为个位数。如39=3+9

#include<iostream>
using namespace std;
#define N 1000007
int main()
{
char ss
;
while(cin>>ss){
if(ss[0]=='0')
break;
int sum=0;
for( int i=0;ss[i];i++)
{
int s=ss[i]-'0';
sum+=s;
if(sum>9)
sum=sum%10+sum/10;
}
cout<<sum<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: