您的位置:首页 > 其它

hdoj 3342 Legal or Not 【拓朴排序】

2015-08-18 11:15 351 查看


Legal or Not

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/O



hers)

Total Submission(s): 6078 Accepted Submission(s): 2824



Problem Description

ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many "holy cows" like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When someone has questions,
many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost "master", and Lost will have a nice "prentice". By and by, there are many pairs of "master and prentice". But then problem occurs: there are too many masters and too
many prentices, how can we know whether it is legal or not?

We all know a master can have many prentices and a prentice may have a lot of masters too, it's legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian's master and, at the same time, 3xian
is HH's master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not.

Please note that the "master and prentice" relation is transitive. It means that if A is B's master ans B is C's master, then A is C's master.

Input

The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <= 100). Then M lines follow, each contains a pair of (x, y) which means x is y's master and
y is x's prentice. The input is terminated by N = 0.

TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,..., N-1). We use their numbers instead of their names.

Output

For each test case, print in one line the judgement of the messy relationship.

If it is legal, output "YES", otherwise "NO".

Sample Input

3 2
0 1
1 2
2 2
0 1
1 0
0 0


Sample Output

YES
NO分析:判断是否能进行拓朴排序。
代码1:
#include<cstdio>
#include<cstring>
#include<cstdlib>
int map[110][110];
int n,m;
int vis[110];

bool topo()
{
int i,j,m;
for(i=0;i<n;i++)
{
m=n;
for(j=0;j<n;j++)
{
if(vis[j]==0){
m=j;
break;
}
}
if(m==n)
return false;
vis[m]=-1;
for(j=0;j<n;j++)
if(map[m][j]>0)
vis[j]--;
}
return true;
}

int main()
{
bool flag;
int a,b;
while(scanf("%d%d",&n,&m)!=EOF,n||m)
{
memset(map,0,sizeof(map));
memset(vis,0,sizeof(vis));
for(int i=0;i<m;i++)
{
scanf("%d%d",&a,&b);
if(map[a][b]==0)
map[a][b]=1,vis[b]++;
}
flag=topo();
if(flag)
printf("YES\n");
else
printf("NO\n");
}
//system("pause");
return 0;
}

代码2:
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;

int n,m;
int vis[110];
struct node{
int next,to;
};
node pp[110];
int head[110];

bool topo()
{
int i,j, m,t;
for(j=0;j<n;j++)
{
m=n;
for(i=0;i<n;i++)
{
if(vis[i]==0)
{
m=i;
break;
}
}
if(m==n)
return false;
vis[m]=-1;
for(int k=head[m];k!=-1;k=pp[k].next)
vis[pp[k].to]--;
}
}

int main()
{
while(scanf("%d%d",&n,&m)!=EOF,n||m)
{
int a,b;
bool flag;
memset(vis,0,sizeof(vis));
memset(head,-1,sizeof(head));
for(int i=0;i<m;i++)
{
scanf("%d%d",&a,&b);
pp[i].to=b;
pp[i].next=head[a];
head[a]=i;
vis[b]++;
}
flag=topo();
if(flag)
printf("YES\n");
else
printf("NO\n");
}
// system("pause");
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: