您的位置:首页 > 其它

HDU 2122 Ice_cream’s world III

2015-08-18 10:10 375 查看
B - Ice_cream’s world III
Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u
SubmitStatus

Description

ice_cream’s world becomes stronger and stronger; every road is built as undirected. The queen enjoys traveling around her world; the queen’s requirement is like II problem, beautifies the roads, by which there are some ways from every
city to the capital. The project’s cost should be as less as better.

Input

Every case have two integers N and M (N<=1000, M<=10000) meaning N cities and M roads, the cities numbered 0…N-1, following N lines, each line contain three integers S, T and C, meaning S connected with T have a road will cost C.

Output

If Wiskey can’t satisfy the queen’s requirement, you must be output “impossible”, otherwise, print the minimum cost in this project. After every case print one blank.

Sample Input

2 1
0 1 10

4 0


Sample Output

10

impossible


最小生成树基础题目。

Prim算法。

#include <stdio.h>
#include <string.h>
#include <algorithm>
#define INF 0x3f3f3f3f
#define N 1005
using namespace std;
int graph

;
int dis
,vis
;
int main()
{
int n,m;
while(scanf("%d%d",&n,&m)>0)
{
memset(vis,0,sizeof(vis));
for(int i = 0; i < n; i++)
{
graph[i][i] = 0;
for(int j = 0; j < i; j++)
graph[i][j] = graph[j][i] = INF;
}
int s,t,c;
while(m--)
{
scanf("%d%d%d",&s,&t,&c);
graph[s][t]=graph[t][s]=min(graph[s][t],c);
}
vis[0]=1;
for(int i=0;i<n;i++)
dis[i]=graph[0][i];
int minn,v,sum=0;
for(int j=1;j<n;j++)
{
minn=INF,v=-1;
v=-1;
for(int i=0;i<n;i++)
if(!vis[i])
minn=minn>dis[i]?dis[v=i]:minn;
if(v==-1)
break;
vis[v]=1;
sum+=minn;
for(int i=0;i<n;i++)
if(!vis[i])
dis[i] = min(graph[v][i],dis[i]);
}
if(v==-1)
printf("impossible\n");
else
printf("%d\n",sum);
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: