您的位置:首页 > 其它

HDU 2289 Cup

2015-08-17 22:49 375 查看

Cup

Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5597 Accepted Submission(s): 1787


[align=left]Problem Description[/align]
The
WHU ACM Team has a big cup, with which every member drinks water. Now,
we know the volume of the water in the cup, can you tell us it height?

The radius of the cup's top and bottom circle is known, the cup's height is also known.

[align=left]Input[/align]
The input consists of several test cases. The first line of input contains an integer T, indicating the num of test cases.
Each
test case is on a single line, and it consists of four floating point
numbers: r, R, H, V, representing the bottom radius, the top radius, the
height and the volume of the hot water.

Technical Specification

1. T ≤ 20.
2. 1 ≤ r, R, H ≤ 100; 0 ≤ V ≤ 1000,000,000.
3. r ≤ R.
4. r, R, H, V are separated by ONE whitespace.
5. There is NO empty line between two neighboring cases.

[align=left]Output[/align]
For each test case, output the height of hot water on a single line. Please round it to six fractional digits.

[align=left]Sample Input[/align]

1
100 100 100 3141562

[align=left]Sample Output[/align]

99.999024

[align=left]Source[/align]
The 4th Baidu Cup final

[align=left]Recommend[/align]
lcy | We have carefully selected several similar problems for you: 2298 2899 2199 2141 1551

只要想到用二分就好做了,浮点数用减法小于某个很小的数表示相等。

#include<queue>
#include<math.h>
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;

#define LL long long
#define N 123456789
#define M 1234
const double PI = acos(-1.0);
const double ee = 1e-8;

double r,R,H,V,v;

double calc(double h)
{
double x=r+h/H*(R-r);
return PI*h*(r*r+x*x+r*x)/3;
}

int main()
{
int t;cin>>t;
while(t--)
{
scanf("%lf%lf%lf%lf",&r,&R,&H,&V);
double ll=0,rr=H,mid;
while(ll<=rr)
{
mid=(ll+rr)/2;
v=calc(mid);
if(fabs(v-V)<=ee)
break;
else if(v<V)
ll=mid+ee;
else
rr=mid-ee;
}
printf("%.6f\n",mid);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: