您的位置:首页 > 其它

POJ 2823 Sliding Window

2015-08-17 22:32 453 查看

Sliding Window

Time Limit: 12000ms
Memory Limit: 65536KB
This problem will be judged on PKU. Original ID: 2823
64-bit integer IO format: %lld Java class name: Main

An array of size n ≤ 106 is given to you. There is a sliding window of size k which is moving from the very left of the array to the very right. You can only see the k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example: The array is [1 3 -1 -3 5 3 6 7], and k is 3.

Your task is to determine the maximum and minimum values in the sliding window at each position.

Input

The input consists of two lines. The first line contains two integers n and k which are the lengths of the array and the sliding window. There are n integers in the second line.

Output

There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values.

Sample Input

8 3
1 3 -1 -3 5 3 6 7

Sample Output

-1 -3 -3 -3 3 3
3 3 5 5 6 7

Source

POJ Monthly--2006.04.28

解题:单调队列,太JB卡时间了,需要使用MS C++提交

#include <cstdio>
#include <cctype>
using namespace std;
const int maxn = 2000010;
int n,k,d[maxn],q[maxn<<1];
inline bool xiao(int a,int b) {
return a <= b;
}
inline bool da(int a,int b) {
return a >= b;
}
inline bool scan_d(int &num) {
bool IsN = false;
char in = getchar();
if(in == EOF) return false;
while(in != '-' && !isdigit(in)) in = getchar();
if(in == '-') {
IsN = true;
num = 0;
} else num = in - '0';
while((in = getchar()) && isdigit(in)) num = num*10 + in - '0';
if(IsN) num = -num;
return true;
}
void solve(bool (*f)(int,int)) {
int hd = 0,tl = 0;
for(int i = 0; i < n; ++i) {
while(hd < tl && q[hd] + k - 1 < i) hd++;
while(hd < tl && f(d[i],d[q[tl-1]])) tl--;
q[tl++] = i;
if(i + 1 >= k) printf("%d%c",d[q[hd]],i + 1 == n?'\n':' ');
}
}
int main() {
scanf("%d%d",&n,&k);
for(int i = 0; i < n; ++i)
scan_d(d[i]);
solve(xiao);
solve(da);
return 0;
}


View Code
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: