您的位置:首页 > 其它

poj-2503 Babelfish

2015-08-17 21:00 351 查看
Description
You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.
Input
Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language
word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.
Output
Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as "eh".

Sample Input
dog ogday
cat atcay
pig igpay
froot ootfray
loops oopslay

atcay
ittenkay
oopslay

Sample Output
cat
eh
loops

题意:为后一个字符串与前一个相关联,先输入联系隔一个空行,之后输入后面的字符串找对应前面的。
思路:由于给的时间很长用map可以水过去(我果断就水过去了),也可以用字典树做,速度会快很多。中间的空行有点坑,需要用gets()读入然后用sscanf将两个字符分开。因为scanf不能让回车通过,也就是一直回车会卡在scanf不动。本人闲得没事写了个不用gets和sscanf的写法,会附在代码中作为注释。
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <map>
#include <string>
using namespace std;
int main()
{
char a[33],b[33],c[33];
map<string,string>Q;
while(gets(c))
{
if(strlen(c)==0) break;
sscanf(c,"%s %s",a,b);
Q[b]=a;
}
/* while(1)                                                                   //没事干的写法,通过这个可以找到一定要用上面的写法的原因
     {
         t=0;
         while(a[t]=getchar(),a[t]!=' '&&a[0]!='\n') t++;
         if(a[0]!='\n') a[t]='\0';
         if(a[0]=='\n') break;
         scanf("%s%*c",b);
        Q[b]=a;
     }*/
 while(scanf("%s",a)!=EOF)
{
if(Q.count(a))
{
cout<<Q[a]<<endl;
}
else
{
printf("eh\n");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: