您的位置:首页 > Web前端

[dfs]poj2718 Smallest Difference

2015-08-17 18:55 267 查看
Time Limit:1000MS Memory Limit:65536KB 64bit IO Format:%I64d & %I64u

Submit

Status

Description

Given a number of distinct decimal digits, you can form one integer by choosing a non-empty subset of these digits and writing them in some order. The remaining digits can be written down in some order to form a second integer. Unless the resulting integer is 0, the integer may not start with the digit 0.

For example, if you are given the digits 0, 1, 2, 4, 6 and 7, you can write the pair of integers 10 and 2467. Of course, there are many ways to form such pairs of integers: 210 and 764, 204 and 176, etc. The absolute value of the difference between the integers in the last pair is 28, and it turns out that no other pair formed by the rules above can achieve a smaller difference.

Input

The first line of input contains the number of cases to follow. For each case, there is one line of input containing at least two but no more than 10 decimal digits. (The decimal digits are 0, 1, …, 9.) No digit appears more than once in one line of the input. The digits will appear in increasing order, separated by exactly one blank space.

Output

For each test case, write on a single line the smallest absolute difference of two integers that can be written from the given digits as described by the rules above.

Sample Input

1

0 1 2 4 6 7

Sample Output

28

题意:给出最多10个数字,将它们划分为两个整数,求差异值最小的值。注意不能出现前导零。

由题意很容易推出,若输入n个数字,那么其中一个数字是n/2位,另一个数字是n-n/2位,用dfs枚举并计算位数为n的所有情况,计算出最小值即可。

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<set>
#include<vector>
#include<map>
#include<string>
#include<iostream>
#include<queue>
using namespace std;
typedef long long ll;
const int inf = 0x3f3f3f3f;
int T,ans,n;
int vis[15];
int a[15],b[15];

void dfs(int k,int aa) //k是位数, aa是当前取出来的数
{
if (k== n/2)
{
int len = 0;
int bb = 0;
for(int i = 0;i<n;i++)
if (!vis[i])
{
b[len++] = a[i];
bb = bb*10+a[i];
}
if (b[0] != 0 || len == 1)
ans = min(ans,abs(aa-bb));
while(next_permutation(b,b+len))
{
bb = 0;
for(int i = 0;i<len;i++)
bb = bb*10+b[i];
if (b[0] != 0  || len ==1)
ans = min(ans,abs(aa-bb));
}
return;
}
for(int i = 0; i < n; i++)
{
if (!vis[i])
{
if (a[i] ==0 && k==0 && n > 3)
continue;
vis[i] = true;
dfs(k+1,aa*10+a[i]);
vis[i] = false;
}
}
}

int main()
{
scanf("%d",&T);
getchar();
while(T--)
{
n = 0;
char ch;
while((ch=getchar()) != '\n')
{
if (ch==' ')
continue;
a[n++] = ch-'0';
}
ans=inf;
memset(vis, 0, sizeof vis);
dfs(0,0);
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: