您的位置:首页 > 其它

HDOJ 2717 Catch That Cow【BFS】

2015-08-17 18:26 453 查看

Catch That Cow

Time Limit: 5000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 9665 Accepted Submission(s): 3022



Problem Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer
John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute

* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?




Input
Line 1: Two space-separated integers: N and K




Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.




Sample Input
5 17






Sample Output
4

HintThe fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.



第一次用BFS,有点小紧张,理解了思路并且参考了一下别人的代码,最终写对了~~



#include<stdio.h>
#include<queue>
#include<string.h>
#include<algorithm>
using namespace std;

int vis[200010], n, m;

struct node{
	int x, step;
} qq;
queue <node> q;

int bfs(){
	while(!q.empty()){
		q.pop();
	}
	q.push(qq);
	memset(vis, 0, sizeof(vis));
	vis[qq.x] = 1;
	while(!q.empty()){
		node gg = q.front();
		if(gg.x == m) return gg.step;
		q.pop();
		int i;
		for(i = 0; i < 3; ++i){
			node dd = gg;
			if(i == 0)
			dd.x += 1;
			if(i == 1)
			dd.x -= 1;
			if(i == 2)
			dd.x = dd.x * 2;
			dd.step++;
			if(dd.step == m)
			return dd.step;
			if(dd.x >= 0 && dd.x <= 200000 && !vis[dd.x]){
				vis[dd.x] = 1;
				q.push(dd);
			}
		}
	}
	return 0;
}

int main(){
	while(~scanf("%d%d", &n, &m)){
		qq.x = n;
		qq.step = 0;
		int s = bfs();
		printf("%d\n", s);
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: