您的位置:首页 > 其它

poj 2431 Expedition(优先队列)

2015-08-17 16:04 302 查看
题目链接
http://poj.org/problem?id=2431
Expedition

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9243 Accepted: 2700
Description

A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck's fuel tank. The truck now leaks one unit of fuel every unit of distance
it travels. 

To repair the truck, the cows need to drive to the nearest town (no more than 1,000,000 units distant) down a long, winding road. On this road, between the town and the current location of the truck, there are N (1 <= N <= 10,000) fuel stops where the cows
can stop to acquire additional fuel (1..100 units at each stop). 

The jungle is a dangerous place for humans and is especially dangerous for cows. Therefore, the cows want to make the minimum possible number of stops for fuel on the way to the town. Fortunately, the capacity of the fuel tank on their truck is so large that
there is effectively no limit to the amount of fuel it can hold. The truck is currently L units away from the town and has P units of fuel (1 <= P <= 1,000,000). 

Determine the minimum number of stops needed to reach the town, or if the cows cannot reach the town at all. 

Input

* Line 1: A single integer, N 

* Lines 2..N+1: Each line contains two space-separated integers describing a fuel stop: The first integer is the distance from the town to the stop; the second is the amount of fuel available at that stop. 

* Line N+2: Two space-separated integers, L and P
Output

* Line 1: A single integer giving the minimum number of fuel stops necessary to reach the town. If it is not possible to reach the town, output -1.
Sample Input
4
4 4
5 2
11 5
15 10
25 10

Sample Output
2

题目大意;
你需要驾驶卡车行驶L单位距离,一开始卡车有P单位的汽油,卡车每开1单位需要消耗1单位的汽油。如果在途中车上的汽油耗尽,卡车就无法继续前行。在途中一共有N个加油站。第i个加油站在距离终点Ai 单位距离的地方,最多可以给卡车加Bi单位的汽油,问卡车能否到达终点,如果可以最少需要加多少次汽油。

思路:

在到达加油站 i 时就获得了一次在之后的任何时候都可以加Bi 单位汽油的权利。因为希望到达终点时加油次数尽可能少,所以当燃料为0了之后再进行加油。在燃料为0时,应该选能加油量Bi最大的加油站。

代码

#include<cstdio>
#include<iostream>
#include<cstring>
#include<queue>
#include<algorithm>
using namespace std;
const int MAXN=10000+10;
struct point
{
int dis;
int val;
bool operator<(const point&a)const{
return val<a.val;
}
}a[MAXN];
bool cmp(const point &a,const point &b){
return a.dis<b.dis;
}
int main()
{
int n,p,l;
while(~scanf("%d",&n))
{
for(int i=1;i<=n;i++)
scanf("%d%d",&a[i].dis,&a[i].val);
scanf("%d%d",&l,&p);
for(int i=1;i<=n;i++)
a[i].dis=l-a[i].dis;
a[++n].dis=l;
a[0].dis=0;
sort(a,a+n,cmp);
priority_queue<point> q;
int cnt=0;
for(int i=1;i<=n;i++)
{
int d=a[i].dis-a[i-1].dis;
while(d>p){
if(q.empty()){
printf("-1\n");
goto end;
}
p+=q.top().val;
q.pop();
cnt++;
}
p-=d;
q.push(a[i]);
}
printf("%d\n",cnt);
end:;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj 优先队列