您的位置:首页 > 其它

POJ_1050_ToTheMax

2015-08-17 14:04 375 查看
To the Max

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 43794Accepted: 23206
Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the
sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.

As an example, the maximal sub-rectangle of the array:

0 -2 -7 0

9 2 -6 2

-4 1 -4 1

-1 8 0 -2

is in the lower left corner:

9 2

-4 1

-1 8

and has a sum of 15.

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines).
These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
Output

Output the sum of the maximal sub-rectangle.
Sample Input
4
0 -2 -7 0 9 2 -6 2
-4 1 -4  1 -1

8  0 -2

Sample Output
15

Source

Greater New York 2001

第一次写二维的树状数组,完全自己从一维推过来的

给自己点个赞。确实像有一本书上那样说的,二维树状数组不是一个多难的东西……

基本裸的二维树状数组

穷举下矩阵的范围就可以了,

用下容斥原理,把不需要的部分去掉

另外我把和都存储下来了,这样应该会省去一部分的运算

#include <iostream>
#include <stdio.h>
using namespace std;

typedef long long LL;
const int M=105;
LL tree[M][M];
LL su[M][M];

inline int lowbit(int x)
{
return x&(-x);
}

void add(int x,int y,LL v)
{
for(int i=x;i<M;i+=lowbit(i))
for(int j=y;j<M;j+=lowbit(j))
tree[i][j]+=v;
}

LL getsum(int x,int y)                       //左上为1,1右下角为x,y的矩阵的和
{
LL s=0;
for(int i=x;i;i-=lowbit(i))
for(int j=y;j;j-=lowbit(j))
s+=tree[i][j];
return s;
}

LL getsu(int stx,int edx,int sty,int edy)        //左上stx,sty右下edx,edy的矩阵的和
{
return su[edx][edy]-su[stx-1][edy]-su[edx][sty-1]+su[stx-1][sty-1];
}

int main()
{
int n;
int num;
LL ans=-1e9;
//freopen("1.in","r",stdin);
scanf("%d",&n);
for(int i=1;i<=n;i++)
for(int j=1;j<=n;j++)
{
scanf("%d",&num);
add(i,j,num);
}
//cout<<"1"<<endl;
for(int i=1;i<=n;i++)
for(int j=1;j<=n;j++)
su[i][j]=getsum(i,j);
for(int stx=1;stx<=n;stx++)
for(int edx=stx;edx<=n;edx++)
for(int sty=1;sty<=n;sty++)
for(int edy=sty;edy<=n;edy++)
ans=max(ans,getsu(stx,edx,sty,edy));
printf("%I64d\n",ans);

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: