您的位置:首页 > 其它

zoj 3203 Light Bulb,三分之二的基本问题

2015-08-17 11:56 323 查看
Light Bulb

Time Limit: 1 Second Memory Limit: 32768 KB

Compared to wildleopard's wealthiness, his brother mildleopard is rather poor. His house is narrow and he has only one light bulb in his house. Every night, he is wandering in his incommodious
house, thinking of how to earn more money. One day, he found that the length of his shadow was changing from time to time while walking between the light bulb and the wall of his house. A sudden thought ran through his mind and he wanted to know the maximum
length of his shadow.



Input

The first line of the input contains an integer T (T <= 100), indicating the number of cases.

Each test case contains three real numbers H, h and D in one line. H is the height of the light bulb while h is the height of mildleopard. D is
distance between the light bulb and the wall. All numbers are in range from 10-2 to 103, both inclusive, and H - h >= 10-2.

Output

For each test case, output the maximum length of mildleopard's shadow in one line, accurate up to three decimal places..

Sample Input

3
2 1 0.5
2 0.5 3
4 3 4


Sample Output

1.000
0.750
4.000


注意精度这题最低是eps = 1e-8;

#include<cstdio>

const double eps = 1e-8;

double H, h, D;
double f(double x)
{
return H-(H-h)*D/x + D-x;
}
int main()
{
int t;
scanf("%d", &t);
while(t--)
{
scanf("%lf%lf%lf", &H, &h, &D);
double l = D-h*D/H, r = D;
double ans = -100;
while(l+eps<r)
{
double m1 = l + (r-l)/3;
double m2 = r - (r-l)/3;
if(f(m1)<f(m2)) l = m1, ans = f(m2);
else r = m2, ans = f(m1);
}
printf("%.3f\n", ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: