您的位置:首页 > 其它

POJ 1017 Packets(贪心)

2015-08-17 11:55 323 查看
解题思路:优先往里面放大的物品。具体不同尺寸怎么放需要画个图,自己数一数。

Description

A factory produces products packed in square packets of the same height h and of the sizes 1*1, 2*2, 3*3, 4*4, 5*5, 6*6. These products are always delivered to customers in the square parcels of the same height h as the products have and of the size 6*6. Because
of the expenses it is the interest of the factory as well as of the customer to minimize the number of parcels necessary to deliver the ordered products from the factory to the customer. A good program solving the problem of finding the minimal number of parcels
necessary to deliver the given products according to an order would save a lot of money. You are asked to make such a program.

Input

The input file consists of several lines specifying orders. Each line specifies one order. Orders are described by six integers separated by one space representing successively the number of packets of individual size from the smallest size 1*1 to the biggest
size 6*6. The end of the input file is indicated by the line containing six zeros.

Output

The output file contains one line for each line in the input file. This line contains the minimal number of parcels into which the order from the corresponding line of the input file can be packed. There is no line in the output file corresponding to the last
``null'' line of the input file.

Sample Input

0 0 4 0 0 1 
7 5 1 0 0 0 
0 0 0 0 0 0


Sample Output

2 
1


#include<algorithm>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cmath>
#include<list>
#include<iostream>
#include<map>
#include<queue>
#include<set>
#include<stack>
#include<vector>

using namespace std;

#define MAX_N
const int INF = 0x3f3f3f3f;
int main()
{
    int s1, s2, s3, s4, s5, s6;
    while(scanf("%d%d%d%d%d%d", &s1, &s2, &s3, &s4, &s5, &s6) && (s1+s2+s3+s4+s5+s6))
    {
        int ans = 0;
        ans += s6;
        ans += s5;
        s1 = max(0 , s1 - s5 * 11);
        ans += s4;
        if(s2 >= s4 * 5)
            s2 = s2 - s4 * 5;
        else
        {
            s1 = max(0, s1 - (s4 * 5 - s2) * 4);
            s2 = 0;
        }
        ans+= (s3 + 3) /4;
        int tmp = s3 % 4;
        if(tmp == 1)
        {
            s2 = max(0, s2 - 5);
            s1 = max(0, s1 - 7);
        }
        else if(tmp == 2)
        {
            s2 = max(0, s2 - 3);
            s1 = max(0, s1 - 6);
        }
        else if(tmp == 3)
        {
            s2 = max(0, s2 - 1);
            s1 = max(0, s1 - 5);
        }
        ans += (s2 + 8) / 9;
        tmp = s2 % 9;
        if(tmp > 0)
        {
            s1 = max(0, s1 - (36 - tmp * 4));
        }
        ans += (s1 + 35) / 36;
        cout<<ans<<endl;
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: