您的位置:首页 > 编程语言 > Go语言

HDU 4722 Good Numbers

2015-08-17 11:17 597 查看
If we sum up every digit of a number and the result can be exactly divided by 10, we say this number is a good number.

You are required to count the number of good numbers in the range from A to B, inclusive.

Input

The first line has a number T (T <= 10000) , indicating the number of test cases.

Each test case comes with a single line with two numbers A and B (0 <= A <= B <= 10 18).

Output

For test case X, output "Case #X: " first, then output the number of good numbers in a single line.

Sample Input

2
1 10
1 20


Sample Output

Case #1: 0
Case #2: 1


打表看出来

每十位中有一个 最后要判断一下

#include <stdio.h>

int pd(long long a)
{
long long k=0;
while(a)
{
k+=a%10;
a/=10;
}
if(k%10!=0)
return 0;
else return 1;
}

int main()
{
int T;
long long res,a,b,sum,t;
scanf("%d",&T);
for(int qq=1;qq<=T;qq++)
{
scanf("%lld %lld",&a,&b);
while(!pd(a))a++;
while(!pd(b))b--;
if(a>b)res=0;
else res=b/10-a/10+1;
printf("Case #%d: %lld\n",qq,res);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: