您的位置:首页 > 其它

浙江大学PAT_甲级_1015. Reversible Primes (20)

2015-08-17 06:52 423 查看
题目链接:点击打开链接

A reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (< 105) and D (1 < D <= 10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line "Yes" if N is a reversible prime with radix D, or "No" if not.
Sample Input:
73 10
23 2
23 10
-2

Sample Output:
Yes
Yes
No

我的Java代码:
import java.util.*;
import java.math.*;
import static java.lang.System.*;
public class Main
{
public boolean IsPrime(int value)//判断素数方法
{
int i = 2;
if (value == 0 || value == 1)
return false;
for (i=2; i <=Math.sqrt(value); i++)
{
if (value%i == 0)
return false;
}
return true;
}
public int reverse(int num,int d)//将10进制数字转换为d进制,并翻转,再转换为10进制
{
int sum=0;
do
{
sum=sum*d+num%d;
num=num/d;
}while(num!=0);
return sum;
}
public static void main(String[] args)
{
Scanner cin=new Scanner(in);
Main m=new Main();
int num=0,d=1;//num输入的数字,d进制
while(cin.hasNextInt())
{
num=cin.nextInt();
if(num<0)//输入负数结束
break;
d=cin.nextInt();
if(m.IsPrime(num)&&m.IsPrime(m.reverse(num, d)))//num是质数,且翻转后还是质数
{
out.println("Yes");
}
else
{
out.println("No");
}
}
}
}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: