您的位置:首页 > 其它

UVa 10340 - All in All

2015-08-16 23:19 176 查看
https://uva.onlinejudge.org/external/103/10340.pdf

10340 All in All

You have devised a new encryption technique which encodes a message by inserting between its characters

randomly generated strings in a clever way. Because of pending patent issues we will not discuss in

detail how the strings are generated and inserted into the original message. To validate your method,

however, it is necessary to write a program that checks if the message is really encoded in the final

string.

Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove

characters from t such that the concatenation of the remaining characters is s.

Input

The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII

characters separated by whitespace. Input is terminated by EOF.

Output

For each test case output, if s is a subsequence of t.

Sample Input

sequence subsequence

person compression

VERDI vivaVittorioEmanueleReDiItalia

caseDoesMatter CaseDoesMatter

Sample Output

Yes

No

Yes

No

分析:

给两个串,让你判断能否在第二个串中(不改变顺序)去掉一些字符(也可以不去),得到第一个串。

直接匹配。

复杂度:O(len2)

#include <iostream>
#include <sstream>
#include <iomanip>
#include <vector>
#include <deque>
#include <list>
#include <set>
#include <map>
#include <stack>
#include <queue>
#include <bitset>
#include <string>
#include <numeric>
#include <algorithm>
#include <functional>
#include <iterator>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <cctype>
#include <complex>
#include <ctime>
#define INF 0x3f3f3f3f
#define eps 1e-6

typedef long long LL;

const double pi = acos(-1.0);
const long long mod = 1e9 + 7;

using namespace std;

char s1[100005];
char s2[100005];

int main()
{
//freopen("int.txt","r",stdin);
//freopen("out.txt","w",stdout);
while(scanf("%s %s",s1,s2) == 2)
{
int len1 = strlen(s1);
int len2 = strlen(s2);
int i = 0;
//printf("%s\n%s\n",s1,s2);
for(int j = 0;j < len2;j++)
{
if(s1[i] == s2[j])
i++;
if(i == len1)
break;
}
if(i == len1)
puts("Yes");
else
puts("No");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: