您的位置:首页 > 其它

poj 2481 cows 树状数组

2015-08-16 10:33 281 查看
题目:

Farmer John's cows have discovered that the clover growing along the ridge of the hill (which we can think of as a one-dimensional number line) in his field is particularly good.

Farmer John has N cows (we number the cows from 1 to N). Each of Farmer John's N cows has a range of clover that she particularly likes (these ranges might overlap). The ranges are defined by a closed interval [S,E].

But some cows are strong and some are weak. Given two cows: cowi and cowj, their favourite clover range is [Si, Ei] and [Sj, Ej]. If Si <= Sj and Ej <= Ei and Ei - Si > Ej - Sj, we say that cowi is stronger than cowj.

For each cow, how many cows are stronger than her? Farmer John needs your help!

Input
The input contains multiple test cases.

For each test case, the first line is an integer N (1 <= N <= 105), which is the number of cows. Then come N lines, the i-th of which contains two integers: S and E(0 <= S < E <= 105) specifying the start end location respectively of a
range preferred by some cow. Locations are given as distance from the start of the ridge.

The end of the input contains a single 0.
Output
For each test case, output one line containing n space-separated integers, the i-th of which specifying the number of cows that are stronger than cowi.

Sample Input
3
1 2
0 3
3 4
0

Sample Output
1 0 0

Hint
Huge input and output,scanf and printf is recommended.
分析:良心的Hint啊,给出N个区间,问这个区间是多少个区间的真子集。

未排序版的Stars,

#include <stdio.h>
#include <string.h>
#include<iostream>
#include<algorithm>
using namespace std;
const int MAXN=100010;
int c[MAXN];
struct Node
{
    int s,e;
    int index;
}node[MAXN];
int n,cnt[MAXN];
bool cmp(Node a,Node b)
{
    if(a.e==b.e) return a.s<b.s;
    return a.e>b.e;
}
int lowbit(int x)
{
    return x&(-x);
}
void add(int i,int val)
{
    while(i<=n){
        c[i]+=val;
        i+=lowbit(i);
    }
}
int sum(int i)
{
    int s=0;
    while(i>0)
    {
        s+=c[i];
        i-=lowbit(i);
    }
    return s;
}
int main()
{
    while(scanf("%d",&n),n){
        for(int i=1;i<=n;i++){
            scanf("%d%d",&node[i].s,&node[i].e);
            node[i].index=i;
        }
        sort(node+1,node+n+1,cmp);
        memset(c,0,sizeof(c));
        memset(cnt,0,sizeof(cnt));
        cnt[node[1].index]=0;
        add(node[1].s+1,1);
        for(int i=2;i<=n;i++){
            if(node[i].e==node[i-1].e&&node[i].s==node[i-1].s)
                cnt[node[i].index]=cnt[node[i-1].index];
            else
                cnt[node[i].index]=sum(node[i].s+1);
            add(node[i].s+1,1);
        }
        printf("%d",cnt[1]);
        for(int i=2;i<=n;i++)
            printf(" %d",cnt[i]);
        printf("\n");
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: