您的位置:首页 > 编程语言 > Java开发

Java 杭电ACM Train Problem I 1022

2015-08-16 01:23 429 查看
点击打开链接

Problem Description

As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one
railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can't leave until train
B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the
trains can get out in an order O2.









Input

The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample
Input.



Output

The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of
the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.



Sample Input

3 123 321
3 123 312




Sample Output

Yes.
in
in
in
out
out
out
FINISH
No.
FINISH

HintHint 
For the first Sample Input, we let train 1 get in, then train 2 and train 3.
So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1.
In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3.
Now we can let train 3 leave.
But after that we can't let train 1 leave before train 2, because train 2 is at the top of the railway at the moment.
So we output "No.".

解题思路:本题解决很简单,就是火车必须先进后出(栈)不一定需要全部出栈后才能进,只要有出去的就能进来,实际上模拟栈的操作,这里我用的是集合,用LinkedList最好,里面涉及需要得到栈中最后一个以及移除最后一个,(本人之前一直用的Arraylist,坑了有点时间),用加一个,装一个字符串”in“,和出一个”out“,要是条件满足,就输出这些,否则就不输出。
package cn.hncu.acm;

import java.util.LinkedList;
import java.util.Scanner;

public class p1022 {
	public static void main(String[] args) {
		Scanner sc=new Scanner(System.in);
		while(sc.hasNext()){
			int n=sc.nextInt();//接收:题目要求
			String a=sc.next();
			char in[]=a.toCharArray();//收到的字符串变成字符数组
			String b=sc.next();
			char out[]=b.toCharArray();//字符数组
			LinkedList<Character> list =new LinkedList<Character>();//针对这题,采用LinkedList是最实用的,
			int count=0;
			int j=0;
			String path[]=new String[2*n];//记录输出“in”和"out"

			//核心的处理
			for(int i=0;i<in.length;i++){
				list.add(in[i]);//每次加入一个都要进行判断下
				path[count++]="in";//把in加入数组path中
				while(!list.isEmpty()&&j<n&&list.getLast()==out[j]){//判断,出栈的是否和压栈(首先第一个)的一样,若一样,则表示有出去的
						path[count++]="out";//标记为“out”
						list.removeLast();//移除最后进来的一个对象(采用LinkedList的优势就在这里,之前采用Arraylist这个问题很难解决,果断采用这个LinkedList)
						
						j++;//每次比较之后就开始进行下一个比较。
				}
			}
			
			//输出
			if(list.isEmpty()){//若是空栈,说明出去完成,输出es
				System.out.println("Yes.");
				for(int i=0;i<path.length;i++){
					System.out.println(path[i]);//输出路径
				}
			}else{
				System.out.println("No.");//否则输出no
			}
			System.out.println("FINISH");//最后输出完成
		}

	}

}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: