您的位置:首页 > 大数据 > 人工智能

hdoj1789Doing Homework again

2015-08-15 23:17 519 查看


Doing Homework again

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 8967 Accepted Submission(s): 5294



Problem Description

Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final
test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.



Input

The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.

Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced
scores.



Output

For each test case, you should output the smallest total reduced score, one line per test case.



Sample Input

3
3
3 3 3
10 5 1
3
1 3 1
6 2 3
7
1 4 6 4 2 4 3
3 2 1 7 6 5 4




Sample Output

0
3
5
#include<stdio.h>
#include<algorithm>
#include<queue>
using namespace std;
#define max 1050
struct line
{
    int code;
    int day;
}num[max];
bool cmp(line a,line b)
{
    return a.day<b.day ;
}
int main()
{
    priority_queue<int ,vector<int >,greater<int > >q;//队列从小到大进行排列 
    int n;
    scanf("%d",&n);
    while(n--)
    {
        int m,i;
        scanf("%d",&m);
        for(i=0;i<m;i++)
        scanf("%d",&num[i].day );
        for(i=0;i<m;i++)
        scanf("%d",&num[i].code );
        sort(num,num+m,cmp);
        while(q.size() !=0)
        q.pop() ;
        int top=0,sum=0;
        for(i=0;i<m;i++)
         {
             if(q.size()<num[i].day )//如果日期没过,加入队列 
              {
                  q.push(num[i].code ) ;
              }
              else//如果队列过了,与队首对比,如分数大于队首,队首弹出,高分入队,否则队列不变 
              {
                  int t=q.top() ;
                  if(num[i].code >t)
                  {
                      q.pop();
                      sum+=t;
                      q.push(num[i].code );   
                  }
                else 
                sum+=num[i].code;
              }
         }
       printf("%d\n",sum);
        
    }
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: