您的位置:首页 > 其它

Codeforces 130A - Testing Pants for Sadness(解题报告)

2015-08-15 22:29 351 查看
Testing Pants for SadnessCrawling in process...
Crawling failed
Time Limit:2000MS
Memory Limit:262144KB
64bit IO Format:
%I64d & %I64u

Submit

Status
Practice
CodeForces 103A

Description

The average miner Vaganych took refresher courses. As soon as a miner completes the courses, he should take exams. The hardest one is a computer test called "Testing Pants for Sadness".

The test consists of n questions; the questions are to be answered strictly in the order in which they are given, from question
1 to question n. Question
i contains ai answer variants, exactly one of them is correct.

A click is regarded as selecting any answer in any question. The goal is to select the correct answer for each of the
n questions. If Vaganych selects a wrong answer for some question, then all selected answers become unselected and the test starts from the very beginning, from question
1 again. But Vaganych remembers everything. The order of answers for each question and the order of questions remain unchanged, as well as the question and answers themselves.

Vaganych is very smart and his memory is superb, yet he is unbelievably unlucky and knows nothing whatsoever about the test's theme. How many clicks will he have to perform in the worst case?

Input

The first line contains a positive integer n (1 ≤ n ≤ 100). It is the number of questions in the test. The second line contains space-separated
n positive integers
ai (1 ≤ ai ≤ 109),
the number of answer variants to question i.

Output

Print a single number — the minimal number of clicks needed to pass the test it the worst-case scenario.

Please do not use the %lld specificator to read or write 64-bit integers in С++. It is preferred to use the cin, cout streams or the %I64d specificator.

Sample Input

Input
2
1 1


Output
2


Input
2
2 2


Output
5


Input
1
10


Output
10


Sample Output

Case #1: 15.707963
Case #2: 2.250778


Hint

Note to the second sample. In the worst-case scenario you will need five clicks:

the first click selects the first variant to the first question, this answer turns out to be wrong.

the second click selects the second variant to the first question, it proves correct and we move on to the second question;

the third click selects the first variant to the second question, it is wrong and we go back to question 1;

the fourth click selects the second variant to the first question, it proves as correct as it was and we move on to the second question;

the fifth click selects the second variant to the second question, it proves correct, the test is finished.

参考代码:

#include<stdio.h>
#define ll __int64
int main()
{
int n;
ll a[105];
ll sum;
while(~scanf("%d",&n))
{
sum=0;
for(int i=1;i<=n;i++)
scanf("%I64d",&a[i]);
for(int i=1;i<=n;i++)
sum+=(i-1)*(a[i]-1)+a[i];
printf("%I64d\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: