您的位置:首页 > 其它

九度oj 1039

2015-08-15 21:33 281 查看
题目描述:

You are given a sequence of integer numbers. Zero-complexity transposition of the sequence is the reverse of this sequence. Your task is to write a program that prints zero-complexity transposition of the given sequence.
输入:

For each case, the first line of the input file contains one integer n-length of the sequence (0 < n ≤ 10 000). The second line contains n integers numbers-a1, a2, …, an (-1 000 000 000 000 000 ≤ ai ≤ 1 000 000 000 000 000).
输出:

For each case, on the first line of the output file print the sequence in the reverse order.
样例输入:
5
-3 4 6 -8 9

样例输出:
9 -8 6 4 -3

来源:
2007年上海交通大学计算机研究生机试真题

#include<iostream>
#include<string.h>
#include<stdlib.h>
using namespace std;
int main()
{
int n;
long long a[10001];

while(cin>>n)
{
for(int i=0;i<n;i++)
{
cin>>a[i];
}
for(int i=n-1;i>0;i--)
{
cout<<a[i]<<" ";
}
cout<<a[0]<<endl;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: